LaTeX forum ⇒ BibTeX, biblatex and biberInvocation of BibTeX fails Topic is solved

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
Posts: 10
Joined: Sun May 29, 2011 11:17 pm

Invocation of BibTeX fails

Postby ZeeRaX » Tue Feb 26, 2013 12:20 am

Hi Folks,

I can't figure out why I keep getting this error for a long time already. I'm running a portable version of Texmaker 3.5 and portable TeX Live 2012. Everything is working smooth, but not BibTeX.

TeXmaker settings:
pdfLaTeX: "../bin/win32/pdflatex.exe" -synctex=1 -interaction=nonstopmode %.tex
Bib(la)TeX: "../bin/win32/bibtex.exe %

also tried:
Bib(la)TeX: "../bin/win32/bibtex.exe %.aux

My TeX document:
  1. \documentclass[12pt,a4paper,oneside]{memoir}
  2. \usepackage[numbers]{natbib}
  4. \begin{document}
  5. Random text \citep{petris}
  7. \bibliographystyle{natplain}
  8. \bibliography{literature}
  9. \end{document}

The file "literature.bib":
  1. @Book{petris,
  2. author = "PETRIS, Giovanni a Sonia PETRONE a Patrizia CAMPAGNOLI",
  3. title = "Dynamic linear models with R",
  4. publisher = "Springer",
  5. year = 2009,
  6. address = "Palo Alto",
  7. edition = "3th,",
  8. isbn = "978-0-387-77237"
  9. }

When I run BibTeX I keep getting the following:
Error: could not start the command

Any hints please? I've searched through the web with no success. The issues always ended up with wrong syntax of the complainant.
Last edited by ZeeRaX on Tue Feb 26, 2013 12:42 pm, edited 3 times in total.
TexMaker; Win 7; TeXLive


User avatar
Site Moderator
Posts: 9204
Joined: Fri Feb 02, 2007 12:06 pm

Postby localghost » Tue Feb 26, 2013 11:43 am

ZeeRaX wrote:[…] TeXmaker settings:
pdfLaTeX: "../bin/win32/pdflatex.exe" -synctex=1 -interaction=nonstopmode %.tex
Bib(la)TeX: "../bin/win32/bibtex.exe %

If this is really your TeXmaker setup, then a quotation mark (") is missing in the settings for BibTeX.
  1. "../bin/win32/bibtex.exe" %

LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes

¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

Posts: 10
Joined: Sun May 29, 2011 11:17 pm

Postby ZeeRaX » Tue Feb 26, 2013 12:42 pm

I feel stupid now. You see, I was right about most common issue with BibTex! And I think you all assumed it as well. The problem was in syntax and missing character.
  1. "../bin/win32/bibtex" %

Works fine! Thank you very much sir!

Why I didn't fix this by myself, is due to other commands, they were somehow without second quotation mark as well.
tex.jpg (48.05 KiB) Viewed 4353 times
TexMaker; Win 7; TeXLive

Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 3 guests