LaTeX forum ⇒ Conversion ToolsConversion of EPS Files to PDF in different Folder

Information and discussion about output converters related to LaTeX (e.g. dvips, ps2pdf, ...)
Posts: 6
Joined: Mon May 31, 2010 9:26 pm

Conversion of EPS Files to PDF in different Folder

Postby ckaeel » Sun Feb 10, 2013 5:07 pm

I'm using the following commands to convert EPS files to PDF.
  1. \DeclareGraphicsExtensions{.pdf,.jpg,.png}
  2. \usepackage{epstopdf}
  3. \epstopdfsetup{outdir=./convertedpics/}
  4. \epstopdfDeclareGraphicsRule{.eps}{pdf}{.pdf}{ps2pdf -dEPSCrop -dPDFSETTINGS=/printer -dMaxSubsetPct=100 -dSubsetFonts=true -dEmbedAllFonts=true #1 \OutputFile}

In this way I can use PDFLaTeX and I don't care about the type of figures: EPS, PDF, PNG, etc.

Everything works fine on a machine (Win 7 pro) with TexnicCenter 1.0 + MiKTeX 2.9 x32 (which is an older version without the latest updates; I'm not administrator on that machine so I can't do any update).

On my personal PC (Win 7 pro) with TexnicCenter 1.0 + MiKTeX 2.9x32 (with the latest updates) the conversion doesn't work:

  1. ! Package pdftex.def Error: File `./convertedpics/TESTfigure-eps-converted-to.pdf' not found.

I have reinstalled both MiKTeX and TexnicCenter and still it doesn't work. Windows UAC is disabled, COMODO (with defence+) is disabled too. When I remove the period from ".eps", it works but it takes only the "-dEPSCrop" argument; the other arguments are not considered, and so the fonts aren't embedded.

I have also tried:
  • to move the project files to another partition, thinking that it may be a problem with the path.
  • installing TeXnicCenter x64 + MiKTeX 2.9 x64 (which is the current configuration) and the problem persist.

I have no other ideas left. If you can test this command on your PC, please let a reply.
Last edited by Stefan Kottwitz on Sun Feb 10, 2013 5:25 pm, edited 1 time in total.


Posts: 6
Joined: Mon May 31, 2010 9:26 pm

Postby ckaeel » Sun Feb 17, 2013 5:02 pm

if I use :
  1. \epstopdfDeclareGraphicsRule{.eps}{pdf}{.pdf}{ps2pdf -dEPSCrop #1 \OutputFile}
it removes the original EPS file with a 3kB one :shock:.
Is this the correct way to use epstopdf package, or did I do something wrong ?

Posts: 6
Joined: Mon May 31, 2010 9:26 pm

Postby ckaeel » Sun Feb 24, 2013 1:42 pm

problem solved

Posts: 1
Joined: Mon May 11, 2015 8:35 pm

Postby emroz92 » Mon May 11, 2015 8:38 pm

Hi Chakeel,
I am running the same problem now. Could you please tell me how to get around the error message.

Thanks in advance.

User avatar
Site Moderator
Posts: 4173
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Mon May 11, 2015 9:53 pm

Hi and welcome,
i don't think the user will come here again to check up on the question.
We have enough space for many manny more question, i would suggest you start a new topic and we start analyzing from scratch, just for you. ;-)

Please try with a very minimal example first. If this does not work, please share the example and the log-file with us.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

Return to “Conversion Tools”

Who is online

Users browsing this forum: No registered users and 3 guests