LaTeX forum ⇒ Generalsync with Sumatra pdf config

General information and discussion about TeXnicCenter
Posts: 8
Joined: Mon Jan 04, 2010 10:59 pm

Re: sync with Sumatra pdf config

Postby willsh » Mon Jan 11, 2010 8:30 pm

Oh! That is a good point. There is no pdf generated when I run that build. It works (with errors with the figures) when I run LaTeX => PDF and works fine when I run LaTeX => PS => PDF. Should it work okay if redo the changes I did to LaTeX=>PDF to LaTeX=>PS=>PDF?

The inverse search command is:

  1. C:\PROGRAM FILES\SUMATRAPDF\SUMATRAPDF.EXE -inverse-search "\"C:\Program Files\TeXnicCenter\TEXCNTR.EXE\" /ddecmd \"[goto('%f', '%l')]\""


Posts: 152
Joined: Wed Jan 17, 2007 10:09 pm

Postby MartinC » Tue Jan 12, 2010 7:36 pm

Yes, this should be ok.

Posts: 1
Joined: Wed Jan 13, 2010 7:13 am

Postby etaurus » Wed Jan 13, 2010 7:20 am

Hi willsh,
I'm the guy who wrote the tutorial. I plan to release a new version in the next days. But in the meanwhile maybe this is what you want:

  1. "C:\PROGRAM FILES\SUMATRAPDF\SUMATRAPDF.EXE" -inverse-search "\"C:\Program Files\TeXnicCenter\TEXCNTR.EXE\" /ddecmd \"[goto('%f', '%l')]\""

Please note the extra " around the first path. I have information that these might be neccessary if you have spaces in the pathname. It may be the same thing for all others paths.


Posts: 8
Joined: Mon Jan 04, 2010 10:59 pm

Postby willsh » Wed Jan 13, 2010 6:26 pm

Benjamin, thanks for writing the document. I just figured out what my problem is. It was not the quotation marks, but that suggestion did lead me to figure out what the problem was. It seems that some part of the synctex procedure does not like file names with spaces in them. I had been trying to test synctex with a tex file someone had given me that had a space in its name. I took out the space and suddenly synctex started working.

Sorry, to lead you guys astray with this -- the thing that confused me was that TeXnicCenter produced the pdf without any problem with the space in the name and the output window looked exactly the same with the synctex command line option -- just no pdf was produced. I didn't expect this kind of failure mode for the file name being the problem.

Posts: 4
Joined: Fri May 14, 2010 5:35 pm

Postby NB2010 » Fri Aug 13, 2010 3:12 pm

Sorry to interject on this thread, but just wanted to say thanks to the tutorial writer. The tutorial for me was correct, the issue i was having was not restarting TXC. Its great to be able to jump between TXC and Sumatra. Much appreciated folks

Posts: 1
Joined: Wed Aug 21, 2013 7:57 pm

Postby ah1em » Wed Aug 21, 2013 8:53 pm

i'm sorry too .. i read this all but till now i can not jump from sumatra pdf to TXC and when i compile sumatra display the page in which i compile


User avatar
Site Moderator
Posts: 4186
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Thu Aug 22, 2013 7:25 am

Texniccenter 2 (it's a beta) and Sumatra should work together out of the box. If not, have a look at TeXnicCenter 2 Beta with Sumatra PDF. Maybe How to configure TXC2 with sumatra might also help.

I advice you to use Texniccenter 2, cause it has full unicode support (this is also the default inputencoding). If you don't want to re-encode your files and stick with latin1, just change it in the preferences.

Best regards
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests