LaTeX forum ⇒ Texmaker and TeXstudio[TexMakerX]: Forward & Inverse Search

Information and discussion about Texmaker, an integrated LaTeX environment for several platforms, and the related TeXstudio
Posts: 21
Joined: Thu Oct 29, 2009 12:18 pm

[TexMakerX]: Forward & Inverse Search

Postby steinchen » Sat Dec 05, 2009 7:17 pm

I have read through the manual. But still not make it succeed :cry: . I have tried following:

Environment Setup:
  • OS: Windows XP sp3
  • SW: TexMakerX 1.9.3 + MiKTeX 2.8 + Sumatra PDF
  • Configure: PDF viewer: "C:\Program Files\SumatraPDF\SumatraPDF.exe" "?am.pdf"
  • User Command 1:
  • User Command 2:
    • Menu Item: InverseSearch
    • Command: "C:\Program Files\TexMakerX\texmakerx.exe" %f -line %l

Method 1:
  • Quick Build: LaTeX + View PDF
  • After quick build, Sumatra PDF shows my result and jump to a page, but it is not my present location in TexMakerX. Message board shows Process excited normally.
  • Select User Command 1, the location in Sumatra PDFnot changed.
  • Select User Command 2, TexMakerX jump and open a new TeX file(untitled) tab, the location not changed, double click in PDF: "synchronization file cannot be opened."
  • I noticed also no synchronization file was generated in the file directory.

Method 2:
  • Quick Build: Command User: pdflatex -interaction=nonstopmode -synctex=-1 %.tex|"C:\Program Files\SumatraPDF\SumatraPDF.exe" "?m.pdf"
  • After quick build, Sumatra PDF shows wrong location(as Method 1).
  • But synchronization file(myfile.synctex) built,
  • Message board shows: Process started, Tex file is blocked not allow to edit. Menus are also blocked cannot select User Commands.
  • Double click on PDF, Error shows: "cannot start inverse search command, please check command line in settings"
  • Close PDF, select view PDF button, it jumps to a wrong location.
  • Select ForwardSearch(User Command 1), PDF shows: "no result found at line 9 in file myfile.tex"
  • Select InverseSearch(User Command 2), same as Method 1.
Please help, thanks in advance!

Posts: 2
Joined: Sat Apr 24, 2010 11:42 pm

Postby valasaru » Sat Apr 24, 2010 11:44 pm

Hi, as I posted in the SF forum page benibela posted, here is how I use it:

so far, it works correctly :)

Return to “Texmaker and TeXstudio”

Who is online

Users browsing this forum: No registered users and 3 guests