LaTeX forum ⇒ GeneralHow to disable ligatures?

LaTeX specific issues not fitting into one of the other forums of this category.
Monkey D
Posts: 22
Joined: Thu Nov 01, 2007 6:12 pm

How to disable ligatures?

Postby Monkey D » Sun Feb 17, 2008 1:54 pm

Is there any way to disable ligatures at a global level?

I hate it when "fi" gets replaced by one character... and I'm sure there are lots of other cases.
Many people like latex because of this feature... Well, no me... it's just a really annoying way to ruin search in pdf files! :x

Thank you.

User avatar
localghost
Site Moderator
Posts: 9204
Joined: Fri Feb 02, 2007 12:06 pm

Postby localghost » Sun Feb 17, 2008 2:41 pm

Try a postscript font from the psnfss (Postscript New Font Selection Scheme) or other fonts like the pxfonts (Palatino style) or txfonts (Times style). Other nice (almost complete) font shapes are provided by the kpfonts and libertine. All these fonts should preferably be used with T1 encoding (Cork Encoding).


Best regards
Thorsten¹
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

A.ndi
Posts: 1
Joined: Tue Dec 30, 2008 2:26 pm

Postby A.ndi » Tue Dec 30, 2008 2:30 pm

disable ligatures:

  1. \usepackage{microtype}
  2. \DisableLigatures{encoding = *, family = * }


Best regards,
Andreas

Keta
Posts: 63
Joined: Tue Nov 25, 2008 1:00 pm

Postby Keta » Fri Jan 02, 2009 2:21 pm

it's just a really annoying way to ruin search in pdf files!


What kind of package, compiler, viewer, etc. are you using? I did a try, and using both latex and pdflatex the "fi" string was searchable with Evince.


Return to “General”

Who is online

Users browsing this forum: No registered users and 10 guests