LaTeX forum ⇒ Texmaker and TeXstudioGeneration of Bibliography Control File fails Topic is solved

Information and discussion about Texmaker, an integrated LaTeX environment for several platforms, and the related TeXstudio
bovic
Posts: 2
Joined: Wed Nov 20, 2013 5:40 pm

Generation of Bibliography Control File fails

Postby bovic » Wed Nov 20, 2013 5:53 pm

Hi there!

I'm putting this in the TeX Live forum because I am guessing this might be a package incompatibility issue.

I'm using TeXmaker with TeX Live 2013 on Windows 7, fully updated. I have looked around a lot for this issue but couldn't find a working fix. I'm using a minimal example I found online - it is behaving the same way in my main document, thus I think it is a valid example and a fix would work on all documents on my machine.

my build command is this:
  1. pdflatex -synctex=1 -interaction=nonstopmode %.tex
  2. biber %
  3. pdflatex -synctex=1 -interaction=nonstopmode %.tex


Minimal (not) working example:
  1. \listfiles
  2. \documentclass{article}
  3. \usepackage[backend=biber]{biblatex}
  4.  
  5. \usepackage{filecontents}
  6. \begin{filecontents*}{\jobname.bib}
  7. @misc{A01,
  8. author = {Author, A.},
  9. year = {2001},
  10. title = {Alpha},
  11. }
  12. \end{filecontents*}
  13.  
  14. \addbibresource{\jobname.bib}
  15.  
  16. \begin{document}
  17. Some text \autocite{A01}.
  18.  
  19. \printbibliography
  20. \end{document}[/latex]
  21.  
  22. debug.blg
  23. [code=none][0] Config.pm:318> INFO - This is Biber 1.8
  24. [0] Config.pm:321> INFO - Logfile is 'debug.blg'
  25. [74] biber-MSWIN:272> INFO - === %a %b %e, %Y, %H:%M:%S
  26. [383] Utils.pm:185> ERROR - Cannot find control file 'debug.bcf'! - did you pass the "backend=biber" option to BibLaTeX?
  27. [383] Biber.pm:109> INFO - ERRORS: 1


The log file "debug.log" is attached.
Attachments
debug.log
(12.92 KiB) Downloaded 2386 times
Last edited by localghost on Wed Nov 20, 2013 9:09 pm, edited 1 time in total.
Reason: Longer passages of source code are tagged as code block, not as in-line code.

Tags:

bovic
Posts: 2
Joined: Wed Nov 20, 2013 5:40 pm

Postby bovic » Wed Nov 20, 2013 6:03 pm

Argh! Right after posting I found the failure. TeXmaker lets you do stuff in a build directory. Biber doesn't know that.

Changing the TeXmaker command to this works.
  1. pdflatex -synctex=1 -interaction=nonstopmode %.tex
  2. biber build/%
  3. pdflatex -synctex=1 -interaction=nonstopmode %.tex

I guess I'm letting this thread stay here for other people to find.


Return to “Texmaker and TeXstudio”

Who is online

Users browsing this forum: No registered users and 2 guests