LaTeX forum ⇒ LyXLyx broke after update

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
user31782937
Posts: 2
Joined: Wed Oct 03, 2018 3:46 pm

Lyx broke after update

Postby user31782937 » Wed Oct 03, 2018 4:01 pm

Yesterday I installed a lot of updates recommended by the software update app in Xubuntu 18.04. Today Lyx is not working properly. I have found (up to now) two problems:

1) Problem with the super index behavior. I cannot enter into "superscript mode" using keyboard anymore (I mean, pressing AltGR+{ and then space bar, in my Spanish keyboard (see this image https://d25rq8gxcq0p71.cloudfront.net/language-guide/758/es-keyboard.jpg)). I have to press the "superscript button" from the toolbar which is annoying. Here I let a screenshot that may help to illustrate the problem:
Image

2) The other problem has to do with the screen refresh after auto-completion in math mode has occurred. The fact is that if I write, for example, "\fra" and then I hit "enter" in order to autocomplete, it effectively autocompletes but the screen does not update until I press other keys or hover the mouse over the math box. To illustrate in a more clearer way I have made a little screencast in this link https://www.dropbox.com/s/uzv5atvoafaeioe/screencast.mp4?dl=0

I have already tried to reinstall Lyx. For reference, this is my Lyx version:

Image

user31782937
Posts: 2
Joined: Wed Oct 03, 2018 3:46 pm

Postby user31782937 » Thu Oct 04, 2018 1:55 am

The solution I found was to re install version 2.3.0-1 (lyx - 2.3.0-1~artful~ppa1 in [this link][1]). For that, I manually downloaded the packages [fonts-lyx_2.3.0-1~artful~ppa1_all.deb][2], [lyx-common_2.3.0-1~artful~ppa1_all.deb][3] and [lyx_2.3.0-1~artful~ppa1_amd64.deb][4] from [here][5] (which indeed is part of [this][1]). Then I removed the 3 corresponding packages from my computer (manually using Synaptic) and finally I installed the downloaded packages using "right click --> software manager". Now I have Lyx 2.3.0-1 in Xubuntu 18.04 happily running, and will not update for a long time.


[1]: https://launchpad.net/~lyx-devel/+archi ... /+packages
[2]: https://launchpad.net/~lyx-devel/+archi ... a1_all.deb
[3]: https://launchpad.net/~lyx-devel/+archi ... a1_all.deb
[4]: https://launchpad.net/~lyx-devel/+archi ... _amd64.deb
[5]: https://launchpad.net/~lyx-devel/+archi ... hive-extra

User avatar
Stefan Kottwitz
Site Admin
Posts: 9106
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Thu Oct 04, 2018 7:26 am

Great, that you found a solution! Thanks for posting it. Looks like bugs in the newest version, that should be fixed.

Btw. once .deb package have been downloaded they can also be installed at the command prompt by dpkg -i.

Stefan
Site admin


Return to “LyX”

Who is online

Users browsing this forum: No registered users and 4 guests