LaTeX forum ⇒ MiKTeX and proTeXtProblems with installing MikTeX

Information and discussion about MikTeX distribution for Windows and the related proTeXt: Installing, updating, configuring
User avatar
T3.
Posts: 208
Joined: Fri Mar 14, 2008 12:58 pm

Re: Problems with installing MikTeX

Postby T3. » Tue Nov 11, 2008 11:59 pm

At least now we know exactly what exactly is failing - registration of core miktex dlls. Unfortunately I don't know what could be the cause of it. I have no problems running registration/unregistration on my system even if the dlls are already registered:
  1. F:\>mpm --register-components --verbose
  2. configuring fontconfig\config\fonts.conf
  3. registering C:\Program Files\MiKTeX 2.7\miktex\bin\MiKTeX207-core.dll
  4. registering C:\Program Files\MiKTeX 2.7\miktex\bin\MiKTeX207-core-PS.dll
  5. registering C:\Program Files\MiKTeX 2.7\miktex\bin\MiKTeX207-packagemanager.dll
  6. registering C:\Program Files\MiKTeX 2.7\miktex\bin\MiKTeX207-packagemanager-PS.dll

Perhaps contact MiKTeX developers about it. I don't know what else to suggest. You may also try to register the above dlls manually with regsvr32 and rerun the installation. Maybe that will help.

Cheers,

Tomek

Eva
Posts: 4
Joined: Mon Nov 10, 2008 11:06 am

Postby Eva » Wed Nov 12, 2008 12:23 pm

Hi,

I've actually managed to install MikTeX somehow. Unfortunately I cannot say how. I tried out so many things .. :-/

In fact I think the registering problem has nothing to do with MikTeX but with the registry server - because the error occurs on registering the dlls.
One thing I tried was to call this manually : initexmf --update-fndb --force --mklinks --mkmaps --verbose
The output from this call said something about errors with fonts - maybe the error has something to with this?

Anyhow, one of my several installations of MikTeX managed it to register itself, I could see this calling regedit.exe. Although the installation is still not recognized as "software" component (and therefore not listed in the Software list of the Windows system view), there are all essential exe-files within /miktex/bin - that's sufficient for using WinShell.

In conclusion: The error is still there, it must have something to do with the registry server. Maybe there is somebody who finds that out. But as long as all essential exe-files are installed correctly, I can use them together with my editor at least.

My tip for monsterjet: Have a look at miktext/bin - maybe the required exe's are already complete?! I'll keep my fingers crossed!

Thanks to all for help on this issue!

Kind regards,
Eva

monsterjet
Posts: 8
Joined: Tue Nov 11, 2008 3:15 pm

Postby monsterjet » Wed Nov 12, 2008 9:49 pm

Hi Eva,

maybe you can give me a hint. I mean the more you can narrow my search the better.
By the way, did the installation process complete normally?
Also, I have the .exe files but when i run Lyx and i write some text, it fails later when i try to convert it into pdf, which as far as i know is the moment when miktex is called to perform that action

thanks
Anas

monsterjet
Posts: 8
Joined: Tue Nov 11, 2008 3:15 pm

Postby monsterjet » Thu Nov 13, 2008 12:54 am

@T3
F:\>mpm --register-components --verbose
configuring fontconfig\config\fonts.conf
registering C:\Program Files\MiKTeX 2.7\miktex\bin\MiKTeX207-core.dll
registering C:\Program Files\MiKTeX 2.7\miktex\bin\MiKTeX207-core-PS.dll
registering C:\Program Files\MiKTeX 2.7\miktex\bin\MiKTeX207-packagemanager.dll
registering C:\Program Files\MiKTeX 2.7\miktex\bin\MiKTeX207-packagemanager-PS.dll


After many tests and installations I found that indeed the problem is in running 'mpm.exe --register-components --verbose' which registers the dll files that you mentioned!
The thing is, that I can run it manually, and it works, yet the installation procedure has to do that by itself and obviously shows an error if it does not manage to do that itself. Any clue why it runs manually, but not automatically?

thanks
Anas

Eva
Posts: 4
Joined: Mon Nov 10, 2008 11:06 am

Postby Eva » Thu Nov 13, 2008 10:50 am

Hi Anas,

that's exactly what I also realized: The registering seems to work manually but not automatically. This let me suspect the RegServer and maybe it has nothing to do with these dlls but with the last action before. Due to the registry cleaning I have maybe confused it somehow.

Regarding Lyx: I don't know how it works there, but can't to set the paths to the exe files? This is what I have to do for Winshell. Thus it doesn't matter if the MikTeX installation aborts at the last few registering calls, because all my required exe files exist :-D

Kind regards,
Eva

opsprof
Posts: 2
Joined: Wed Feb 04, 2009 6:33 pm

Postby opsprof » Wed Feb 04, 2009 6:35 pm

I am having the same problem but I am not sure how to manually run the mpm.exe --register-components --verbose. Can you please help me with this last step?

User avatar
localghost
Site Moderator
Posts: 9204
Joined: Fri Feb 02, 2007 12:06 pm

Postby localghost » Wed Feb 04, 2009 7:22 pm

Open a command prompt and type in exactly this line (confirming with Enter).
  1. mpm.exe --register-components --verbose

More information should be available in the MiKTeX 2.7 Manual.


Best regards and welcome to the board
Thorsten¹
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

opsprof
Posts: 2
Joined: Wed Feb 04, 2009 6:33 pm

Postby opsprof » Wed Feb 04, 2009 10:24 pm

Thanks Thorsten,

When I do this however, I get the same error message that I got when trying to install MiKTeK.

C:\mpm.exe --register-components --verbose:
configuring fontconfig\config\fonts.conf
registering C:\Program Files\MiKTeX 2.7\miktex\bin\MiKTeX207-core.dll
mpm.exe: regsvr failed for some reason.

doe
Posts: 1
Joined: Sun Apr 19, 2009 6:15 pm

Postby doe » Sun Apr 19, 2009 6:17 pm

Try Checking your virus checker. Mine was blocking mpm.exe from running.

kingcrunch
Posts: 4
Joined: Wed May 20, 2009 3:36 pm

Postby kingcrunch » Wed May 20, 2009 3:54 pm

Hi all,

I've been trying to install MikTex 2.7 now for almost 3 days and it just won't work.

I had the same errors as described earlier in this thread:
The installation didn't finish properly:

...
problem: C:\Programme\LaTex\MiKTeX 2.7\miktex\bin\MiKTeX207-core-PS.dll does not exist
problem: C:\Programme\LaTex\MiKTeX 2.7\miktex\bin\MiKTeX207-core.dll does not exist
problem: C:\Programme\LaTex\MiKTeX 2.7\miktex\bin\MiKTeX207-packagemanager-PS.dll does not exist
problem: C:\Programme\LaTex\MiKTeX 2.7\miktex\bin\MiKTeX207-packagemanager.dll does not exist
...
An error occurred:
source file: C:\work3\miktex-2.7\Libraries\MiKTeX\Core\Process.cpp
source line: 296
message: The operation failed for some reason.
info: C:\Programme\LaTex\MiKTeX 2.7\miktex\bin\mpm.exe

I've tried the command mpm --register-components --verbose. After I had switched off my virus scanner, it worked and the dll-files were registered.
But the main problem that occured when I tried to integrate MikTex into TeXnicCentre is that the necessary .exe files (latex.exe, pdflatex.exe...) are not in the miktex\bin folder!

I've deleted and reinstalled MikTex several times, in versions 2.5, 2.6 and 2.7. It's always the same problem that the important .exe files are missing!

Can anyone please help?

Thx!
Rainer


Return to “MiKTeX and proTeXt”

Who is online

Users browsing this forum: No registered users and 2 guests