LaTeX forum ⇒ MiKTeX and proTeXtPdflatex Randomly started Hanging up Topic is solved

Information and discussion about MikTeX distribution for Windows and the related proTeXt: Installing, updating, configuring
MattyMo
Posts: 3
Joined: Sun Oct 20, 2013 6:58 pm

Pdflatex Randomly started Hanging up

Postby MattyMo » Wed Jan 04, 2017 3:08 am

Hello everyone,

I am working on my dissertation and randomly, pdflatex started to hang up and my document would not compile anymore. It would just sit there. I wasn't doing anything crazy or anything, just doing minor punctuation and sentence corrections. I even commented out the chapter I was working on and it still did not compile. I tried updating the Miktex packages (as per a possible solution I found whilst googling) and I get the error:

Sorry, but something went wrong:

The executed process did not succeed.

fileName = "C:\Program Files\MiKTeX 2.9\miktex\bin\x64\initexmf.exe",
arguments = "--force --mklinks --verbose", exitCode="1"


No idea what this means. I tried compiling the document on two different computers, but neither worked. I can compile other documents, just not my dissertation.

I just saw now, whilst coming on these forums, that there was an update. Could that have something to do with it?

Thanks!!

User avatar
Stefan Kottwitz
Site Admin
Posts: 8954
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Wed Jan 04, 2017 3:31 am

Hi MattyMo,

welcome to the forum!

This is one message, but did you get other error messages? Was it the same error message on the other computer?

Can you please post the .log file of such a failed run, as attachment here?

Stefan
Site admin

MattyMo
Posts: 3
Joined: Sun Oct 20, 2013 6:58 pm

Postby MattyMo » Wed Jan 04, 2017 4:56 am

I do not see any log file in the folder. I see a .lof and a.lot, but no .log. (EDIT: The compiling never completes, I always have to hit the stop button)

I use TeX Studio for my editor, and there is a tab on the bottom that says "Log." When I click on it, it says:

error line 10: Paragraph ended before \l@table was complete. ...k or <return> to continue without it.}\par
error line 10: Missing { inserted. ...t it.} \par \let \reserved

Both of these errors are said to be in the .lot file which stores table information. Which as this as line 10:

\contentsline {table}{\numberline {5.1}{\ignorespaces Change factors associated with Figure 5.1\hbox {}. Scatterer Numbers for each iteration are shown below the change factors. \GenericError { }{LaTeX Error: There's no line here to end}{See the LaTeX manual or LaTeX Companion for explanation.}{Your command was ignored.\MessageBreak Type I <command> <return> to replace it with another command,\MessageBreak or <return> to continue without it.}\par \let \reserved@d = *\def \par }}{122}

So I figured, "Okay, this looks simple, the last thing I was doing was correcting a entry in a table, maybe I accidentally deleted something."

So I commented out the entire chapter and it still hangs when I try to compile.

User avatar
Stefan Kottwitz
Site Admin
Posts: 8954
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Wed Jan 04, 2017 12:21 pm

Remove the .lot file and test again. It could still have the entry with the problem. It will be regenerated anyway.

Stefan
Site admin

MattyMo
Posts: 3
Joined: Sun Oct 20, 2013 6:58 pm

Postby MattyMo » Wed Jan 04, 2017 3:45 pm

Wow that did it! Thanks so much!!


Return to “MiKTeX and proTeXt”

Who is online

Users browsing this forum: No registered users and 4 guests