LaTeX forum ⇒ MiKTeX and proTeXtPale Font in PDF Output Topic is solved

Information and discussion about MikTeX distribution for Windows and the related proTeXt: Installing, updating, configuring
kenny5432
Posts: 2
Joined: Sat Nov 09, 2013 2:47 pm

Pale Font in PDF Output

Postby kenny5432 » Sat Nov 09, 2013 3:03 pm

I have been using LaTeX for a couple of months now and I have notice that MiKTeX is producing PDF that looks pale. I didn't have this problem before and it's just started recently. I kept an old PDF and compiled again the same code to show the difference.

Thank you for your help.
Attachments
after.pdf
(164.24 KiB) Downloaded 372 times
Before.pdf
(187.89 KiB) Downloaded 365 times

Tags:

User avatar
localghost
Site Moderator
Posts: 9204
Joined: Fri Feb 02, 2007 12:06 pm

Postby localghost » Sat Nov 09, 2013 5:53 pm

Probably a font encoding problem. Looking at the document properties regarding the used fonts reveals that "before.pdf" contains high quality Type 1 fonts whereas "after.pdf" only uses Type 3 fonts of lower quality.

You can check that either in the document properties of your PDF viewer or by the command line tool »pdffonts« (part of XPDF).

The command line tool gives me this for "before.pdf" …
  1. name type encoding emb sub uni object ID
  2. ------------------------------------ ----------------- ---------------- --- --- --- ---------
  3. ZXQTCI+SFCC2074 Type 1 Custom yes yes no 5 0
  4. SMFHIK+SFCC1440 Type 1 Custom yes yes no 6 0
  5. KZZLAX+SFRM1000 Type 1 Custom yes yes no 7 0
  6. CLTPYJ+SFRM1200 Type 1 Custom yes yes no 8 0
  7. MEHLID+SFBX1728 Type 1 Custom yes yes no 13 0

… and this for "after.pdf".
  1. name type encoding emb sub uni object ID
  2. ------------------------------------ ----------------- ---------------- --- --- --- ---------
  3. [none] Type 3 Custom yes no no 5 0
  4. [none] Type 3 Custom yes no no 6 0
  5. [none] Type 3 Custom yes no no 7 0
  6. [none] Type 3 Custom yes no no 8 0
  7. [none] Type 3 Custom yes no no 13 0

The reason could be that after a new setup of the TeX system the cm-super package is not installed or that inside the document the Type 1 encoding has been turned off (I'm not really sure). This line enables the »Cork Encoding« (Type 1 encoding).
  1. \usepackage[T1]{fontenc}

For texts in other languages than English (e.g most European languages) you should use T1 encoding.


Best regards and welcome to the board
Thorsten
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

kenny5432
Posts: 2
Joined: Sat Nov 09, 2013 2:47 pm

Postby kenny5432 » Sun Nov 10, 2013 5:39 am

Thank you very much. you were right, the cm-super package was not installed.


Return to “MiKTeX and proTeXt”

Who is online

Users browsing this forum: No registered users and 1 guest