LaTeX forum ⇒ MiKTeX and proTeXtGeneral Connection Problems Topic is solved

Information and discussion about MikTeX distribution for Windows and the related proTeXt: Installing, updating, configuring
Posts: 3
Joined: Thu Nov 03, 2016 11:31 pm

Re: General Connection Problems

Postby Teuto » Fri Nov 04, 2016 12:18 am


I am using Miktex 2.9 on windows 10 and can't choose a repository in the package manager to get the necessary packages.
This error pops up in the Miktex Problem Report: ="socket failed in tcp_connect()"

Can you help me?

I already checked if there is a proxy: negative. And i also deactivated the firewall and antivirus software.



User avatar
Stefan Kottwitz
Site Admin
Posts: 8708
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany

Postby Stefan Kottwitz » Fri Nov 04, 2016 8:54 am

Hi Teuto,

welcome to the forum!

Try choosing a different repository. Try several. Yes, it could be a proxy setting of Windows or of MiKTeX. Or that repository is down.

Btw. TeX Live is also a great TeX system on Windows. I use it.

Site admin

Posts: 3
Joined: Thu Nov 03, 2016 11:31 pm

Postby Teuto » Sat Nov 05, 2016 2:26 pm

Hi Stefan,

thanks for your answer.
Unfortunately that didn't work out. I wasn't able to even choose any repository because the error appeared before the choosing menu.

I now just reinstalled miktex 2.9
Now, I get the following error: The package definition file could not be parsed.

path="C:\Users\pbem12\AppData\Local\Temp\mik4405\makeindex.tpm", line="2", column="1330"

Any ideas how to solve this?

Thanks a lot!


User avatar
Site Moderator
Posts: 3644
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Sat Nov 05, 2016 3:02 pm

Ulrike Fischer just told me the following:
An error in the tpm. Christian (MikTeX maintainer) wrote on the miktex mailing list "This file cannot be parsed because it contains an error: the character sequence 'Chen & Harrison' should be replaced by 'Chen and Harrison'. I will fix this." Should be sorted out tomorrow.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

Posts: 3
Joined: Thu Nov 03, 2016 11:31 pm

Postby Teuto » Tue Nov 08, 2016 1:34 pm

Hi Johannes,

thank you for your information.
Yes it has been sorted out and it works now on my system.


Return to “MiKTeX and proTeXt”

Who is online

Users browsing this forum: No registered users and 3 guests