LaTeX forum ⇒ Curricula Vitae / RésumésAwesome Resume CV / Fonts not found after LaTex update

ModernCV, Friggeri, Plasmati, Classicthesis-CV, and more
bedazs
Posts: 3
Joined: Sun Mar 29, 2020 3:31 am

Awesome Resume CV / Fonts not found after LaTex update

Postby bedazs » Sun Mar 29, 2020 3:41 am

After a LaTex update, the fonts are not found in the folder anymore. \fontdir is still there and points at the right folder, but on typesetting an error message comes up for each font and the end product is blank.

User avatar
Vel
Site Moderator
Posts: 458
Joined: Fri Jun 29, 2012 1:20 am

Postby Vel » Mon Mar 30, 2020 9:37 am

I just updated my TeX Live distribution (2019) and you're right that the following error comes up on compilation:

Code: [Select all] [Expand/Collapse] [Download] ({untitled.tex})
  1. ./awesome-cv.cls:166: LaTeX3 Error: Command '\FA' already defined!
  2.  
  3. For immediate help type H <return>.
  4. ...
  5.  
  6. l.166 \newfontfamily
  7. \headerfont[


I didn't get any other errors.

That line doesn't actually appear to be doing anything so it can be removed and the template compiles just fine. I'll update the template to remove it.
Founder and administrator of LaTeXTemplates.com and LaTeXTypesetting.com

User avatar
Vel
Site Moderator
Posts: 458
Joined: Fri Jun 29, 2012 1:20 am

Postby Vel » Mon Mar 30, 2020 10:12 am

I've just updated the template to v1.3 to remove that line.
Founder and administrator of LaTeXTemplates.com and LaTeXTypesetting.com

bedazs
Posts: 3
Joined: Sun Mar 29, 2020 3:31 am

Postby bedazs » Tue Mar 31, 2020 6:06 am

Thank you,
I have looked at v1.3, but unfortunately still have the same issue. Error messages and only the header comes up at the end, the rest of the document is blank.

bedazs
Posts: 3
Joined: Sun Mar 29, 2020 3:31 am

Postby bedazs » Tue Mar 31, 2020 6:09 am

/usr/local/texlive/2019/texmf-dist/tex/latex/sourcesanspro/sourcesanspro.sty:12
3: Package fontspec Error: The font "SourceSansPro-Regular" cannot be found.

suepatrick
Posts: 1
Joined: Thu Apr 30, 2020 11:26 am

Postby suepatrick » Thu Apr 30, 2020 11:33 am

bedazs wrote:Thank you,
I have looked at web v1.3, but unfortunately still have the same issue. Error messages and only the header comes up at the end, the rest of the document is blank.


Yeah, I have the same problem. I hope these issues will be fixed soon.


Return to “Curricula Vitae / Résumés”

Who is online

Users browsing this forum: No registered users and 4 guests