LaTeX forum ⇒ Curricula Vitae / Résumésbibliography problem Topic is solved

ModernCV, Friggeri, Plasmati, Classicthesis-CV, and more
templateuser
Posts: 679
Joined: Tue Mar 03, 2015 4:01 pm

bibliography problem

Postby templateuser » Mon Mar 16, 2015 12:50 pm

Hello! I'm quite frustrating on this template. Spent almost a day trying to use it. I'm not so much professional LaTeX user, maybe it is the reason.

1. It seems that Helvetica is commercial font, at least I cannot find where to download it legally for free. So, I replaced Helvetica to TeX-Gyre-Heros. Now it compiles and looking not bad.

2. The main problem is bibliography. I used following sequence: XeLaTeX cv_10 => biber cv_10 => XeLaTeX cv_10
But as result the Publications section is still empty. This is Miktex 2.9.4196 on provided cv_10.tex example.
Any ideas how to solve this issue? Thank in advice!

AlexB

Tags:

User avatar
Vel
Site Moderator
Posts: 454
Joined: Fri Jun 29, 2012 1:20 am

Postby Vel » Mon Mar 16, 2015 12:50 pm

Hi,

You're correct that Helvetica is a commercial font so you have to purchase it in order to use it (or you could get a Mac .

What does the log look like when you run biber on cv_10? Most likely it's telling you what the problem is. Paste it here and I'll have a look!

Cheers,
Vel
Founder and administrator of LaTeXTemplates.com and LaTeXTypesetting.com

templateuser
Posts: 679
Joined: Tue Mar 03, 2015 4:01 pm

Postby templateuser » Mon Mar 16, 2015 12:50 pm

Hi, Vel

Thank you for your reply

So, I had fixed this problem.
My LaTeX installation was too much old for that stuff.
I had perfomed full update for all packages and now its working.

Nice template, thanks!

AlexB

User avatar
Vel
Site Moderator
Posts: 454
Joined: Fri Jun 29, 2012 1:20 am

Postby Vel » Mon Mar 16, 2015 12:51 pm

Excellent, most problems tend to be caused by outdated LaTeX distributions or packages :)
Founder and administrator of LaTeXTemplates.com and LaTeXTypesetting.com

templateuser
Posts: 679
Joined: Tue Mar 03, 2015 4:01 pm

Postby templateuser » Mon Mar 16, 2015 12:51 pm

Hi,

I have the same problem, bibliography items does not appear. When I execute biber cv_10 in the command prompt I get the following log file

  1. [0] Config.pm:320> INFO - This is Biber 1.9
  2. [1] Config.pm:323> INFO - Logfile is 'cv_10.blg'
  3. [54] biber-MSWIN:274> INFO - === %a %b %e, %Y, %H:%M:%S
  4. [181] Utils.pm:160> ERROR - Cannot find control file 'cv_10.bcf'! - did you pass the "backend=biber" option to BibLaTeX?
  5. [181] Biber.pm:110> INFO - ERRORS: 1


Any ideas? I've already performed an update of all my packages.

Thanks!

mecadin

User avatar
Vel
Site Moderator
Posts: 454
Joined: Fri Jun 29, 2012 1:20 am

Postby Vel » Mon Mar 16, 2015 12:51 pm

Hi,

You could try adding backend=biber to the square bracket of \RequirePackage[...]{biblatex} on line 177 in friggeri-cv.cls.

If that doesn't work, have you made modifications to the template? Are you sure you are running the biber cv_10 command in the directory of the template? To test this, make sure "ls cv_10.tex" isn't returning No such file or directory.

Cheers,
Vel
Founder and administrator of LaTeXTemplates.com and LaTeXTypesetting.com

templateuser
Posts: 679
Joined: Tue Mar 03, 2015 4:01 pm

Postby templateuser » Mon Mar 16, 2015 12:51 pm

Thanks Vel,

I added backend=biber, everything it's working now. I also re-update all my packages.

I modified the friggeri-cv.cls file such that the bibliography items are numbered. This is what I have:

In line 177:
  1. \RequirePackage[defernumbers=true, style=numeric, maxnames=99, sorting=ydnt,
  2. backend=biber]{biblatex}


And a couple of lines before the file ends:

  1. \printbibliography[sorting=chronological, type={#1}, title={#2}, heading=subbibliography,
  2. resetnumbers=true]


In this way I can reset the counter in each refsection in the cv_10.tex file.

l was wondering if it's possible to get the citation numbers to count down and reset the counter in each refsection:

[3] newest item
[2] item
[1] oldest item


Best
mecadin!

User avatar
Vel
Site Moderator
Posts: 454
Joined: Fri Jun 29, 2012 1:20 am

Postby Vel » Mon Mar 16, 2015 12:51 pm

Hey mecadin,

Great, I'm glad it works now!

It doesn't look like it's very easy to do what you ask and I haven't had to do it before. Here's a few resources that might help: http://tex.stackexchange.com/questions/ ... count-down http://tex.stackexchange.com/questions/ ... -numbering http://tex.aspcode.net/view/63539927362 ... count-down

Cheers,
Vel
Founder and administrator of LaTeXTemplates.com and LaTeXTypesetting.com


Return to “Curricula Vitae / Résumés”

Who is online

Users browsing this forum: No registered users and 1 guest