LaTeX forum ⇒ Theses, Books, Title pagesIssues compiling kaobook with TeXStudio

Classicthesis, Bachelor and Master thesis, PhD, Doctoral degree
DMAshura
Posts: 1
Joined: Wed Sep 11, 2019 6:51 am

Issues compiling kaobook with TeXStudio

Postby DMAshura » Wed Sep 11, 2019 7:00 am

Hello everyone,

I've been using LaTeX for a few years now, and I've been looking into writing a math textbook using it. I found the Kaobook template tonight, and tried compiling it in TeXStudio (after running compileall.sh), but I was given the following error messages, most notably the first one:

Code: [Select all] [Expand/Collapse] [Download] ({untitled.tex})
  1. Unknown option `nomencl=false' for package `scrhack'. \KOMAProcessOptions
  2. fixltx2e is not required with releases after 2015(fixltx2e) All fixes are now in the LaTeX kernel.
  3.  
  4. Typearea changed!(typearea) You should do this only at preamble, because only(typearea) \begin{document} calculates output dimensions!(typearea) Trying to calculate new output dimensions, but(typearea) this is only a dirty hack
  5. Font shape `OMS/cmsy/m/n' in size <10.5> not available(Font) size <10.95> substituted
  6. Hyper reference `bhfn:0' on page i undefined
  7.  
  8. Typearea changed!(typearea) You should do this only at preamble, because only(typearea) \begin{document} calculates output dimensions!(typearea) Trying to calculate new output dimensions, but(typearea) this is only a dirty hack


After this were a bunch of overfull and underfull \hbox's.

Strangely, even after these errors, a correct-looking main.pdf popped out after two compiles.

More strangely, Overleaf did not have this problem and compiled everything just fine.

Has anybody else run into this issue and/or have a suggestion for how to fix it? I'm not a beginner with LaTeX, but I'm not an advanced user either.

User avatar
Ijon Tichy
Posts: 132
Joined: Mon Dec 24, 2018 10:12 am

Postby Ijon Tichy » Wed Sep 11, 2019 7:28 am

I do not know the template. But it seems, it is using package scrhack with option nomencl=false. This option is provided since KOMA-Script 3.23, released 2017/04/13. The current official release is KOMA-Script 3.26b. So your LaTeX distribution seems to be far away from being up-to-date. I would recommend an update.

BTW: This is not a problem of the editor TeXstudio but a problem of the TeX distribution, either MiKTeX or TeXLive (or MacTeX version of TeXLive).


Return to “Theses, Books, Title pages”

Who is online

Users browsing this forum: No registered users and 2 guests