LaTeX forum ⇒ Theses, Books, Title pagesReferences style

Classicthesis, Bachelor and Master thesis, PhD, Doctoral degree
Almurshdy
Posts: 5
Joined: Mon Aug 27, 2018 11:15 am

References style

Postby Almurshdy » Wed Oct 24, 2018 12:21 pm

Hi All,

I am using Masters/Doctoral Thesis template.

Please, how can I change the display of et al to full authors names in the list of references?.

Thanks,
Ahmed.

User avatar
Johannes_B
Site Moderator
Posts: 3905
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Wed Oct 24, 2018 1:03 pm

maxbibnames=99
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

Almurshdy
Posts: 5
Joined: Mon Aug 27, 2018 11:15 am

Postby Almurshdy » Wed Oct 24, 2018 1:42 pm

Hi Johannes,

I added this line to the template
\usepackage{maxbibnames=99}
but does not working.

User avatar
Johannes_B
Site Moderator
Posts: 3905
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Wed Oct 24, 2018 2:04 pm

It is an option for biblatex. Please have a look at the package documentation.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

User avatar
Stefan Kottwitz
Site Admin
Posts: 9197
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Thu Oct 25, 2018 6:47 pm

Hi Ahmed,

welcome to the forum!

Find this line in main.tex (maybe line 46):

\usepackage[backend=bibtex,style=authoryear,natbib=true]{biblatex}

Change it to

\usepackage[backend=bibtex,style=authoryear,natbib=true, maxbibnames=99]{biblatex}

Stefan
Site admin

Almurshdy
Posts: 5
Joined: Mon Aug 27, 2018 11:15 am

Postby Almurshdy » Thu Oct 25, 2018 7:32 pm

Hi All,
Last edited by Almurshdy on Thu Oct 25, 2018 7:38 pm, edited 1 time in total.

User avatar
Stefan Kottwitz
Site Admin
Posts: 9197
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Thu Oct 25, 2018 7:36 pm

Did you read my post?

Stefan
Site admin

Almurshdy
Posts: 5
Joined: Mon Aug 27, 2018 11:15 am

Postby Almurshdy » Thu Oct 25, 2018 7:37 pm

Stefan Kottwitz wrote:Hi Ahmed,

welcome to the forum!

Find this line in main.tex (maybe line 46):

\usepackage[backend=bibtex,style=authoryear,natbib=true]{biblatex}

Change it to

\usepackage[backend=bibtex,style=authoryear,natbib=true, maxbibnames=99]{biblatex}

Stefan



Many Thanks, the issue solved.
Ahmed


Return to “Theses, Books, Title pages”

Who is online

Users browsing this forum: No registered users and 2 guests