LaTeX forum ⇒ TeXworksSpellcheck on Windows

Information and discussion about TeXworks, an integrated LaTeX environment for several platforms
mdk31
Posts: 20
Joined: Wed Mar 11, 2009 4:38 am

Spellcheck on Windows

Postby mdk31 » Tue Jan 05, 2010 11:49 pm

I recently installed TexLive 2009 on my Windows Vista laptop and I'm having some trouble with Tex Works. Whenever I go to Edit and try to use the Spellcheck, it will simply say "None." I've delibrately mispelled words to see if it will pick them up but it still says "None."

Tags:

josephwright
Site Moderator
Posts: 814
Joined: Tue Jul 01, 2008 2:19 pm

Postby josephwright » Wed Jan 06, 2010 12:08 am

Did you actually install any dictionaries? None are supplied with TeXworks, which currently needs the OpenOffice-style ones (also used by Firefox and Thunderbird).
Joseph Wright

User avatar
frabjous
Posts: 2064
Joined: Fri Mar 06, 2009 12:20 am

Postby frabjous » Wed Jan 06, 2010 12:10 am

[Sorry, partly redundant post...]

Have you chosen a dictionary? (Under Edit > Spelling in my TeXworks, or to set its default, under Edit > Preferences > Editor > Spell-Check language.)

If so, and it's still not working, it might help to know what version/revision you're using. (Found under Help > About. E.g., I'm using Version 0.3 (r.532)... though for linux.)

mdk31
Posts: 20
Joined: Wed Mar 11, 2009 4:38 am

Postby mdk31 » Wed Jan 06, 2010 12:29 am

frabjous wrote:[Sorry, partly redundant post...]

Have you chosen a dictionary? (Under Edit > Spelling in my TeXworks, or to set its default, under Edit > Preferences > Editor > Spell-Check language.)

If so, and it's still not working, it might help to know what version/revision you're using. (Found under Help > About. E.g., I'm using Version 0.3 (r.532)... though for linux.)


Thanks for your response.

I don't see the choice of "Spelling in my TeXWorks" but when I go to pick Spell-Check language it only gives me the choice of none. I'm using version 0.2.3.

User avatar
frabjous
Posts: 2064
Joined: Fri Mar 06, 2009 12:20 am

Postby frabjous » Wed Jan 06, 2010 3:13 am

It sounds to me as if Joseph was right and you don't have any dictionaries installed.

Follow the advice here for installing them:
http://code.google.com/p/texworks/wiki/ ... ctionaries

mdk31
Posts: 20
Joined: Wed Mar 11, 2009 4:38 am

Postby mdk31 » Wed Jan 06, 2010 7:50 pm

That's probably the reason. I'll try it when I get back to my laptop, thanks.


Return to “TeXworks”

Who is online

Users browsing this forum: No registered users and 3 guests