LaTeX forum ⇒ Viewers for PDF, PS, and DVICannot output to PDF!

Information and discussion about output viewers related to LaTeX (e.g. Adobe Reader, Ghostview, YAP, ...)
maxiness
Posts: 5
Joined: Fri Jan 23, 2009 6:49 pm

Cannot output to PDF!

Postby maxiness » Mon Mar 08, 2010 7:35 pm

Hi Everyone,

I really hope you can help me with my problem, as I really need to start on an assignment!

I have installed the latest version of MikTex, Adobe Acrobat and TexnicCenter. I configured TexnicCenter with MikTex and also checked that the file path for Adobe Acrobat is correct in Define Output Profiles. However, whenever I try to build and view, Adobe opens saying "File Cannot Be Found" and an error in TexnicCenter is given saying "[DocOpen("%bm.pdf")][FileOpen("%bm.pdf")] Cannot execute command".

I've tried other pdf viewers like Sumatra and Foxit, but the same error is given.

I've uninstalled everything and reinstalled to no avail.

Has anyone any ideas?

Thanks!

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm

Postby localghost » Mon Mar 08, 2010 7:51 pm

Check if there is a known issue with MiKTeX 2.8 regarding the cooperation with TeXnicCenter (TXC)[1]. Otherwise make sure even a PDF file is produced by looking at the log file and at your working directory. If necessary, try to compile on the command line.

[1] MiKTeX 2.8 Issues


Best regards
Thorsten
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

maxiness
Posts: 5
Joined: Fri Jan 23, 2009 6:49 pm

Postby maxiness » Mon Mar 08, 2010 8:12 pm

I think there are some errors in the ouput log, but I cant seem to copy it into here for you to look at :S As far as I can see no pdf file was created

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm

Postby localghost » Mon Mar 08, 2010 8:20 pm

The best is to build a minimal example that reproduces the errors. The log file is very clear in describing errors. It gives you the lines where to find and to fix them. If necessary, you can upload the log file (*.log) as attachment to your next post. But providing a MWE including its log file is best.
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

mattia b
Posts: 1
Joined: Thu Nov 10, 2011 12:19 am

Postby mattia b » Thu Nov 10, 2011 7:24 pm

Finally how did you do maxiness??
I have exactly the same problem as you!!
When I try to build and view, I get the same error as you: Adobe opens saying "File Cannot Be Found" and an error in TexnicCenter is given saying "[DocOpen("%bm.pdf")][FileOpen("%bm.pdf")] Cannot execute command". Moreover, only the LOG file is created in the code's folder.
However, I noted that if I try to compile the code with "TeXworks editor previewer" (wich is in MikTek2.9), 3 more files are created in the folder:
- an AUX file
- a ZIP file
- and a PDF file with the right output
I suppose those should be all the right files to obtain from the correct compilation of the TexnicCenter.
So the question is: why I don't get the PDF file from the TeXnicCenter too?

monica
Posts: 1
Joined: Mon Jul 09, 2012 4:36 pm

Postby monica » Mon Jul 09, 2012 4:39 pm

I have the same problem and i have to present a document tomorrow! HELP

Why Texniccenter doesn't open pdf?

User avatar
Stefan Kottwitz
Site Admin
Posts: 9106
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Mon Jul 09, 2012 6:56 pm

Hi Monica,

welcome to the board!

monica wrote:I have the same problem and i have to present a document tomorrow!


To get a quick solution, it would be good if you would provide as much information as possible at once. For example, tell the exact error message, which PDF reader you are using, your TeXnicCenter settings if possible, the .log file as attachment.
Otherwise it's hard to help if we don't know what your're actually doing.

Stefan
Site admin

qulibiao
Posts: 1
Joined: Thu Jul 19, 2018 5:07 pm

Postby qulibiao » Thu Jul 19, 2018 5:20 pm

Have you solved the problem? I have the same problem now!

User avatar
Stefan Kottwitz
Site Admin
Posts: 9106
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Thu Jul 19, 2018 5:34 pm

qulibiao wrote:I have the same problem now!

Welcome to the forum! My previous post above applies here too.

Stefan
Site admin


Return to “Viewers for PDF, PS, and DVI”

Who is online

Users browsing this forum: No registered users and 1 guest