LaTeX forum ⇒ Viewers for PDF, PS, and DVIYet Another Previewer has stopped working

Information and discussion about output viewers related to LaTeX (e.g. Adobe Reader, Ghostview, YAP, ...)
dasci+
Posts: 3
Joined: Sun Dec 24, 2017 3:22 pm

Yet Another Previewer has stopped working

Postby dasci+ » Sun Dec 24, 2017 3:29 pm

Hello,

When I compile a file and view the dvi file, I receive the following message:

"Yet Another Previewer has stopped working
A problem caused the program to stop working correctly.
Windows will close the program and notify you if a
solution is available."

Then it stops working. But it does not happen in every file. BTW, I am using Windows 10. Any help is appreciated,

Thanks.

User avatar
Stefan Kottwitz
Site Admin
Posts: 9733
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Sun Dec 24, 2017 3:48 pm

Welcome to the forum!

Perhaps there's an update available for YAP, or for your MiKTeX or TeX Live? I would check this first. There may be bug fixes.

YAP is for DVI and is partially capable of displaying embedded PostScript graphics (EPS). Non-supported PostScript could crash it. Perhaps check if it's caused by EPS images or by using PSTricks.

Stefan
LaTeX.org admin

dasci+
Posts: 3
Joined: Sun Dec 24, 2017 3:22 pm

Postby dasci+ » Tue Jan 16, 2018 8:49 pm

Thanks Stefan.

Indeed I found out that it is caused by .eps files. However, I used to run these files on Miktex 2.8 without a problem. The problem started when I installed 2.9.

Both the YAP and the Miktex are the latest versions. Any other possibilities?

Thanks again.

dasci+
Posts: 3
Joined: Sun Dec 24, 2017 3:22 pm

Postby dasci+ » Tue Jan 16, 2018 8:49 pm

Thanks Stefan.

Indeed I found out that it is caused by .eps files. However, I used to run these files on Miktex 2.8 without a problem. The problem started when I installed 2.9.

Both the YAP and the Miktex are the latest versions. Any other possibilities?

Thanks again.

Borisba
Posts: 1
Joined: Wed Jul 14, 2021 10:51 am

Postby Borisba » Wed Jul 14, 2021 11:06 am

Hello.

I have the same problem indicated here: I can compile and visualize the output in PdF, but not in DVI, since I get the message

dasci+ wrote:"Yet Another Previewer has stopped working
A problem caused the program to stop working correctly.
Windows will close the program and notify you if a
solution is available."


I have updated MikTeX, refreshed the file name database, clicked on Settings/Format and then clicked on "dvilualatex - DVI Lua La TeX" and then on "Build format", but nothing has worked. I do not have any ".ps" or ".eps" file in the same folder of the LaTeX document, nor any reference to ".ps" or ".eps" file in the LaTeX commands.

Is there anything I could do to solve the issue?


Return to “Viewers for PDF, PS, and DVI”

Who is online

Users browsing this forum: No registered users and 2 guests