LaTeX forum ⇒ Viewers for PDF, PS, and DVIHow to suppess navigation pane in Acrobat Reader

Information and discussion about output viewers related to LaTeX (e.g. Adobe Reader, Ghostview, YAP, ...)
ralphey
Posts: 9
Joined: Wed Feb 03, 2010 8:35 pm

How to suppess navigation pane in Acrobat Reader

Postby ralphey » Wed Feb 03, 2010 8:40 pm

Hi, I'm new to the forum and have benefited a lot in the past from your experience (hoping for more of the same!).

I am using TexnicCenter to compile my tex files using pdflatex. On everything that I compile, Acrobat Reader's navigation panel appears on the left side of my compiled pdf (I do not have professional version). Currently, I need to use the mouse, or hit f4, to make it disappear, and it's, well, rather annoying.

I have searched and searched, but am unable to find a LaTeX command to suppress this navigation panel (with bookmarks, etc.) from appearing. Is there such a command, and if so, can someone tell me what it is? Thanks!

php1ic
Posts: 192
Joined: Wed Jan 28, 2009 8:17 pm

Postby php1ic » Wed Feb 03, 2010 9:22 pm

I searched for this as well, but couldn't find out how to do it. As I didn't actually want the bookmarks, just the internal links, I ended up totally suppressing the bookmarks.

  1. \usepackage[bookmarks=false]{hyperref}

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm
Location: Braunschweig, Germany

Postby localghost » Wed Feb 03, 2010 9:25 pm

I'd say that an appropriate option to the hyperref package should to the trick.
  1. \usepackage[bookmarksopen=false]{hyperref}



Best regards and welcome to the board
Thorsten
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

php1ic
Posts: 192
Joined: Wed Jan 28, 2009 8:17 pm

Postby php1ic » Wed Feb 03, 2010 9:40 pm

Perhaps it's the combination of packages and options I use, but "bookmarksopen=false" doesn't work for me.

  1. \usepackage[pdftex,a4paper,ps2pdf,linkbordercolor={0 0 0},pdfborder={0 0 0},bookmarks=false]{hyperref}

ralphey
Posts: 9
Joined: Wed Feb 03, 2010 8:35 pm

Postby ralphey » Wed Feb 03, 2010 9:44 pm

Thanks localghost and php1ic,

Now I'm getting the following error now when I try to compile: "option clash for package hyperref" (and I'm getting it whether I use \usepackage[bookmarks=false]{hyperref} or \usepackage[bookmarksopen=false]{hyperref} )

I get the same message on 2 separate tex files; while one of the document classes is for a PhD dissertation (proprietary?), the other is Beamer. In both cases I do not believe I have specified anything else for the hyperref package, so I'm not sure what's clashing here.
Last edited by cgnieder on Wed Aug 22, 2012 10:29 pm, edited 1 time in total.
Reason: added inline code markup

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm
Location: Braunschweig, Germany

Postby localghost » Wed Feb 03, 2010 9:47 pm

php1ic wrote:Perhaps it's the combination of packages and options I use, but "bookmarksopen=false" doesn't work for me. [...]

My last reply was an assumption thus a random shot. If your solution works, I'm sure it will be useful for the OP.
ralphey wrote:Now I'm getting the following error now when I try to compile: "option clash for package hyperref" (and I'm getting it whether I use \usepackage[bookmarks=false]{hyperref} or \usepackage[bookmarksopen=false]{hyperref} )

I get the same message on 2 separate tex files; while one of the document classes is for a PhD dissertation (proprietary?), the other is Beamer. In both cases I do not believe I have specified anything else for the hyperref package, so I'm not sure what's clashing here.

For the first case try inserting this option into the option list for the document class. The class will pass it to hyperref. For the beamer class you also have to add something to the option list.
  1. \documentclass[...,hyperref={bookmarks=false},...]{beamer}

For a presentaion it may better to start it in full screen mode right at the beginning.
  1. \documentclass[...,hyperref={pdfpagemode=FullScreen},...]{beamer}

Bookmarks aren't displayed in full screen mode.
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

ralphey
Posts: 9
Joined: Wed Feb 03, 2010 8:35 pm

Postby ralphey » Wed Feb 03, 2010 10:21 pm

Thanks for your excellent suggestions - so I understand correctly, for the non-Beamer tex file are you saying to pass just the option into the document class, like so:

\documentclass[...,bookmarks=false,...]{xyz}?

For the Beamer file, I got it to work great with the fullscreen command. With the hyperref={bookmarks=false} command in the \documentclass options, I also get the PDF to compile, and NO NAVIGATION PANEL!!!, but there are tons of errors, most read "Undefined control sequence <argument> \@outlinefile", or "Missing number, treated as zero. <to be read again>" -> it looks like they are mostly dealing with sections and subsections of my Beamer tex file. Any idea how to remedy this?

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm
Location: Braunschweig, Germany

Postby localghost » Wed Feb 03, 2010 11:17 pm

ralphey wrote:Thanks for your excellent suggestions - so I understand correctly, for the non-Beamer tex file are you saying to pass just the option into the document class, like so:

\documentclass[...,bookmarks=false,...]{xyz}? [...]

Exactly. The class should pass the option to the hyperref package.
ralphey wrote:[...] For the Beamer file, I got it to work great with the fullscreen command. With the hyperref={bookmarks=false} command in the \documentclass options, I also get the PDF to compile, and NO NAVIGATION PANEL!!!, but there are tons of errors, most read "Undefined control sequence <argument> \@outlinefile", or "Missing number, treated as zero. <to be read again>" -> it looks like they are mostly dealing with sections and subsections of my Beamer tex file. Any idea how to remedy this?

Perhaps this contradicts some essential settings in beamer. To find that out, you have to build a minimal working example (MWE) which reproduces the misbehaviour. Follow exactly the instructions for building a MWE.
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

bclyons12
Posts: 3
Joined: Thu May 17, 2012 6:51 pm

Postby bclyons12 » Wed Aug 22, 2012 9:35 pm

This option for the hyperref package seems to do what you want:

  1. \usepackage[pdfpagemode=UseNone]{hyperref}


In this case, the bookmarks will still be created but they will not be displayed when Adobe Reader launches.
Last edited by cgnieder on Wed Aug 22, 2012 10:30 pm, edited 1 time in total.
Reason: added code markup

Courtney McDaniel
Posts: 8
Joined: Mon Apr 16, 2018 11:04 am

Postby Courtney McDaniel » Mon Apr 16, 2018 11:09 am

I would note that some slowing bookmarks infuriate me, but now I carry out to fix them quite simply


Return to “Viewers for PDF, PS, and DVI”

Who is online

Users browsing this forum: No registered users and 1 guest