LaTeX forum ⇒ BibTeX, biblatex and biber? in BibTex References

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
steve de costa
Posts: 19
Joined: Mon Dec 21, 2009 3:01 am

? in BibTex References

Postby steve de costa » Tue Jun 08, 2010 5:12 am

I have been searching for QUITE some time but I'm unable to fix this. When I compile my bibTex, I get the following output in my console

Command Line: bibtex.exe "Main"
The style file: plain.bst
Database file #1: CompleteBibliography.bib
Warning--I didn't find a database entry for "Lami1994"
Warning--I didn't find a database entry for "DataBook"
Name 1 in "Su-Liu Yang, and Chung-Ming Yang" has a comma at the end for entry YangAndYang2005
while executing---line 1049 of file plain.bst
Warning--empty publisher in DependentDataBook
Name 1 in "Su-Liu Yang, and Chung-Ming Yang" has a comma at the end for entry YangAndYang2005
while executing---line 1090 of file plain.bst
(There were 2 error messages)


When I compile my latex, I see "?" everywhere in the pdf output instead of the references. Also, I'm not even able to compile to a dvi file so that I can have links in the pdf output file. Can anyone please help me with this? I've been trying to fix it for DAYS now.

Thanks in advance for any comments/guidance.

User avatar
gmedina
Posts: 2313
Joined: Wed Jul 11, 2007 11:45 pm

Postby gmedina » Tue Jun 08, 2010 6:42 am

Hi,

can you please attach to your next reply the file CompleteBibliography.bib? If the file is too long, then simply copy-paste in your next reply the items having the keys Lami1994 and DataBook.
1,1,2,3,5,8,13,21,34,55,89,144,233,...

CrazyHorse
Posts: 351
Joined: Sat Aug 02, 2008 8:47 am

Postby CrazyHorse » Tue Jun 08, 2010 8:10 am

steve de costa wrote:I have been searching for QUITE some time but I'm unable to fix this. When I compile my bibTex, I get the following output in my console

Command Line: bibtex.exe "Main"
The style file: plain.bst
Database file #1: CompleteBibliography.bib
Warning--I didn't find a database entry for "Lami1994"
Warning--I didn't find a database entry for "DataBook"
Name 1 in "Su-Liu Yang, and Chung-Ming Yang" has a comma at the end for entry YangAndYang2005
while executing---line 1049 of file plain.bst
Warning--empty publisher in DependentDataBook
Name 1 in "Su-Liu Yang, and Chung-Ming Yang" has a comma at the end for entry YangAndYang2005
while executing---line 1090 of file plain.bst
(There were 2 error messages)


When I compile my latex, I see "?" everywhere in the pdf output instead of the references. Also, I'm not even able to compile to a dvi file so that I can have links in the pdf output file. Can anyone please help me with this? I've been trying to fix it for DAYS now.


Warning--I didn't find a database entry for "Lami1994"
Warning--I didn't find a database entry for "DataBook"

you have a reference like \cite{Lami1994} but no such entry
in your data file. Same for DataBook. Compare the spelling and
correct lower/uppercase letters.

Name 1 in "Su-Liu Yang, and Chung-Ming Yang" has a comma at the end for entry YangAndYang2005

should be written as

Su-Liu Yang and Chung-Ming Yang

without the comma!

Warning--empty publisher in DependentDataBook

in the data base entry for DependentDataBook there should be a
publisher = ...
field.

You always get ? in the output, when bibtex fails or you have
not run LaTeX at least twice.

Herbert

steve de costa
Posts: 19
Joined: Mon Dec 21, 2009 3:01 am

Postby steve de costa » Tue Jun 08, 2010 7:48 pm

Hi there,

First of all, THANK YOU so much for your reply.

I made the suggested changes.

I change "Lai1993" to "Lai1995" as it was a tiny mistake.

I also took the "and" out of the authors and now the entry for authors looks like following

author = {Su-Fen Yang, Chung-Ming Yang},


The DependentDatabook is given below and I always had the publisher entry in there.

@Book{DependentDataBook,
author = {S. N. Lahiri},
title = {Resampling Methods for Dependent Data},
pubslisher = {Springer Series in Statistics},
year = {2003},
}


I'm not sure why is it still giving me the following error when I compile my thesis.

I basically have a main file in which I "\include{}" all the other files.

The following are the errors I 'm still getting.

Command Line: bibtex.exe "Main"
Startup Folder: H:\Change Point\MY PROPOSAL\Final Thesis

This is BibTeX, Version 0.99c (MiKTeX 2.8)
The top-level auxiliary file: Main.aux
.
.
.
I found no \bibdata command---while reading file Main.aux
I found no \bibstyle command---while reading file Main.aux
(There were 2 error messages)



The following is at the end of my main file where I'm calling the bibliography file

\addcontentsline{toc}{chapter}{Bibliography}
\bibliographystyle{plain}
\bibliography{CompleteBibliography}


Any idea what's wrong now?

Again, thanks a lot for all your help.

steve de costa
Posts: 19
Joined: Mon Dec 21, 2009 3:01 am

Postby steve de costa » Thu Jun 10, 2010 6:36 am

Anyone???

Any ideas at all?

josephwright
Site Moderator
Posts: 814
Joined: Tue Jul 01, 2008 2:19 pm

Postby josephwright » Thu Jun 10, 2010 7:44 am

I suggest you upload an example of the problem (files we can compile), so that we can have a look for anything important that has not been mentioned.
Joseph Wright

steve de costa
Posts: 19
Joined: Mon Dec 21, 2009 3:01 am

Postby steve de costa » Thu Jun 10, 2010 7:23 pm

Ok, I'll try to make a MWE and post it.

Hope that will help.

Thanks for your response.

Steve


Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 3 guests