LaTeX forum ⇒ BibTeX, biblatex and bibernatbib won't sort&compress - among other things

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
jgassens
Posts: 14
Joined: Sat Dec 20, 2008 3:06 am

natbib won't sort&compress - among other things

Postby jgassens » Mon Dec 22, 2008 8:13 pm

I'm continuing my LaTeX journey and have encountered another problem, this time with references. I'm using natbib but the only argument that works so far is the [super] argument. [sort&compress] crashes the thing.

Not only that, but I'm using hyperref and the links to the references are green, whilst all my other links are black - as they should be.

Finally, even though the references are superscript the commas that separate them are not so, if I have 10 references, they alternate superscript and normal script for the numbers and the commas.

So, those are my 3 problems. Any suggestions?

josephwright
Site Moderator
Posts: 814
Joined: Tue Jul 01, 2008 2:19 pm

Postby josephwright » Mon Dec 22, 2008 8:30 pm

Can you post an example of your source? The [sort&compress] option normally works fine. I suspect that your citation problems might be to do with writing:

\cite{One}\cite{Two}

rather than

\cite{One,Two}

Am I correct?
--
Joseph Wright
Joseph Wright

jgassens
Posts: 14
Joined: Sat Dec 20, 2008 3:06 am

Postby jgassens » Mon Dec 22, 2008 9:02 pm

Nope, I use:

\citet{ref,ref2,ref3,ref4}

I sort of wonder if sort&compress issues are some kind of conflict with something in my documentclass file which can be found here:

http://graduateschool.nd.edu/assets/4694/ndthesis.cls

josephwright
Site Moderator
Posts: 814
Joined: Tue Jul 01, 2008 2:19 pm

Postby josephwright » Mon Dec 22, 2008 9:27 pm

There is nothing obvious in the class, but I may of course have missed something. An example would help, see:

http://www.tex.ac.uk/cgi-bin/texfaq2html?label=minxampl

for example.
--
Joseph Wright
Joseph Wright

jgassens
Posts: 14
Joined: Sat Dec 20, 2008 3:06 am

Postby jgassens » Wed Dec 24, 2008 9:32 pm

I was using /citet{} and not /citep{}

:oops:

It works now. Thanks for your help!


Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 2 guests