LaTeX forum ⇒ BibTeX, biblatex and biberIssue of Bibliography: My .bbl file is empty

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
rodrigue
Posts: 12
Joined: Fri Dec 27, 2019 9:18 am

Issue of Bibliography: My .bbl file is empty

Postby rodrigue » Fri Mar 27, 2020 11:59 am

Hi all,

My greetings to all the users of this forum.
I have a problem with my bibliography. When I run PDFLaTex - >> BibTex - >> PDFLaTex - >> PDFLaTex, the .bbl file is well created but it is empty. I think that's where the problem is. So my bibliography does not display anything at all. The .blg file displays this (all content is shown in attachments)

This is BibTeX, Version 0.99d (MiKTeX 2.9.7380 64-bit)
Capacity: max_strings=200000, hash_size=200000, hash_prime=170003
The top-level auxiliary file: thes.aux
I couldn't open style file apalite.bst
---line 24 of file thes.aux
: \bibstyle{apalite
: }
I'm skipping whatever remains of this command
I found no style file---while reading file thes.aux


It should be noted that I did not encounter this problem before. Everything worked normally until the moment I needed to install a new package. Therefore, the MikTex console which I always used to do it did not work any more when I refreshed the database, I don't know why (I didn't know yet that I could install a package by just activating my connection). So I had to uninstall everything (MikTex and Texmaker) before reinstalling again. This time I installed my packages using the internet connection and it is from this moment that my bibliography does not display anything.
I have tried everything.

For a week I have found similar problems on the internet but no solution so far.

I really think that the package that supports the Natbib bibliography has not been installed properly or something is missing. But what's wrong ? I don't understand anything.

Here is my packages


\documentclass[a4paper, 12pt]{report}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage[T1]{fontenc}
\usepackage[nottoc]{tocbibind}
\usepackage[square,numbers]{natbib}
\usepackage[french]{babel}
\usepackage{lmodern}
\usepackage{array}
\usepackage{rotating}
\usepackage{graphicx}
%\usepackage{natbib}[number]
\usepackage{natbib}[square,sort,comma,numbers]
\usepackage{lscape}
\usepackage{amsmath,amssymb,amsfonts,amsthm}
\usepackage{booktabs}
\usepackage{hyperref}
\usepackage{supertabular}
\usepackage[a4paper]{geometry}
\geometry{hscale=0.79,vscale=0.82,centering}
\usepackage{setspace}
\onehalfspacing
\DeclareMathOperator*{\Max}{Max}
\usepackage{multirow}
\usepackage{multicol}
%\usepackage{glossaries}
%\makeglossaries
\parskip=13pt
\addtocounter{tocdepth}{6}
\setcounter{secnumdepth}{6}
\setcounter{tocdepth}{6}
\renewcommand{\arraystretch}{1}
\newcolumntype{h}{>{\centering\arraybackslash}p{35mm}<{}}
\newcolumntype{D}[1]{>{\centering}p{#1.5}}
%\renewcommand{baselinestretch}{1.5}
%\usepackage[letterspace=150]{microtype}

\bibliographystyle{apalike}

\setcitestyle{authoryear,open={(},close={)}}

\pagenumbering{roman}



\begin{document}
\newlength{\cspace}
\setlength{\cspace}{8pt}
\the\baselineskip\\
\the\columnsep

\setlength{\baselineskip}{8mm}

\the\baselineskip\\

\the\cspace

\hypersetup{linkcolor=blue, citecolor=blue}

\makeatletter
\renewcommand{\@biblabel}[1]{}
\makeatother

\setlength\parindent{1.2cm}

\clearpage\setcounter{page}{2}


\bibliography{mybib}



A small precision. My tex and bib files are in the same folder.

I need your help please


Rodrigue
Attachments
thes.blg
(1.06 KiB) Downloaded 29 times

User avatar
Johannes_B
Site Moderator
Posts: 4185
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Fri Mar 27, 2020 12:32 pm

Did you mean to use apalike?
Not lite
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

rodrigue
Posts: 12
Joined: Fri Dec 27, 2019 9:18 am

Postby rodrigue » Fri Mar 27, 2020 12:48 pm

Hi Johannes_B

Yes I used apalite style. But even plainnat produces the same result

rodrigue
Posts: 12
Joined: Fri Dec 27, 2019 9:18 am

Postby rodrigue » Fri Mar 27, 2020 1:01 pm

Ah !!! I wrote apalite instead of apalike. I just changed it now and it's working. Thinking that just one letter causes that problem...

Thank you very much


Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 3 guests