LaTeX forum ⇒ BibTeX, biblatex and biberBibliography troubles?

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
leakim
Posts: 2
Joined: Wed Jul 31, 2019 11:09 pm

Bibliography troubles?

Postby leakim » Wed Jul 31, 2019 11:22 pm

Hello everyone!

I'm sorry if my question sounds really naïve. I'm a total beginner, and I've tried looking online for this but I can't seem to figure this out.
I'd like to use LateX to write a social sciences article: bibliography and footnotes are thus really important, but I can't seem to link my .bib file to my main .tex file.
I don't think there is a problem with my bibliography per say, as I used Zotero to generate it and did not do it by hand. The .bib file is also in the same directory as my .tex file. All updates seem to have been installed. I have troubles figuring what I'm doing wrong, or why this doesn't work. Once again, I'm sorry if this question sounds naïve, I'm really just starting, but since this is a history article bibliography is one of the first things I need to get right!

Here's what I'm getting from now when I try to add a bibliography to the main file and use it to create footnotes.

Image

Thanks in advance ;)

Lea

User avatar
Ijon Tichy
Posts: 92
Joined: Mon Dec 24, 2018 10:12 am

Postby Ijon Tichy » Thu Aug 01, 2019 8:27 am

You should replace \bibliography by \addbibresource. And have you configured TeXworks to use biber instead of bibtex? See also: https://tex.stackexchange.com/a/154767 and https://tex.stackexchange.com/a/63875.

leakim
Posts: 2
Joined: Wed Jul 31, 2019 11:09 pm

Postby leakim » Thu Aug 01, 2019 8:46 am

I'm using Biber now, and it seems to work! Thank you so much!


Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 2 guests