LaTeX forum ⇒ BibTeX, biblatex and biberNewbie help with order of apperance in Bibtex Topic is solved

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
Calypso
Posts: 5
Joined: Mon Dec 10, 2018 2:16 pm

Newbie help with order of apperance in Bibtex

Postby Calypso » Mon Dec 10, 2018 2:25 pm

I am writting a report in Latex (overleaf) and having trouble sorting my references in order of apperance, can someone help me a bit?
Last edited by Calypso on Mon Dec 10, 2018 11:49 pm, edited 1 time in total.

User avatar
Stefan Kottwitz
Site Admin
Posts: 9244
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Mon Dec 10, 2018 2:28 pm

Hi Calypso,

welcome to the forum!

You could use the sorting=none option:

  1. \usepackage[sorting=none, ...]{biblatex}


Stefan
Site admin

Calypso
Posts: 5
Joined: Mon Dec 10, 2018 2:16 pm

Postby Calypso » Mon Dec 10, 2018 2:32 pm

Thank you!

When I use \usepackage[sorting=none, ...]{biblatex} in the preamble it shows an error when I compile, the whole document turns red.

\usepackage[sorting=none]{biblatex}
Last edited by Calypso on Mon Dec 10, 2018 11:50 pm, edited 2 times in total.

User avatar
Stefan Kottwitz
Site Admin
Posts: 9244
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Mon Dec 10, 2018 2:39 pm

Don't load biblatex twice, but add the option to the existing \usepackage command:

  1. \usepackage[backend=bibtex,
  2. bibencoding=utf8,
  3. sorting=none
  4. ]{biblatex}


I did not edit the command above in my post but used ... since the code in the question was just a screenshot image, not code text that I could copy and paste and edit. ;-)

Stefan
Site admin

Calypso
Posts: 5
Joined: Mon Dec 10, 2018 2:16 pm

Postby Calypso » Mon Dec 10, 2018 2:42 pm

\usepackage[backend=bibtex,
bibencoding=utf8
sorting=none
]{biblatex}
\addbibresource{bib/mybib}

Yet my references still don't show in order of apperance :?
Last edited by Calypso on Mon Dec 10, 2018 11:50 pm, edited 1 time in total.

User avatar
Stefan Kottwitz
Site Admin
Posts: 9244
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Mon Dec 10, 2018 2:44 pm

Perhaps it's because you forgot the comma in the code of the previous post aftert bibencoding=utf8 and before sorting=none so biblatex cannot understand the option.

Stefan
Site admin

Calypso
Posts: 5
Joined: Mon Dec 10, 2018 2:16 pm

Postby Calypso » Mon Dec 10, 2018 2:46 pm

Oh it works now after compiling 10 times, still the red error code appears every second time I compile, but the other times it works just fine

Calypso
Posts: 5
Joined: Mon Dec 10, 2018 2:16 pm

Postby Calypso » Mon Dec 10, 2018 2:46 pm

Thank you so much! :P


Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 7 guests