LaTeX forum ⇒ BibTeX, biblatex and biberbiblatex missing year

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
stegzzz
Posts: 2
Joined: Wed Jul 03, 2013 5:15 pm

biblatex missing year

Postby stegzzz » Wed Jul 03, 2013 5:28 pm

Hi,I have the latex code below. When I compile using TeXstudio the year information is missing from the in-text citation and reference list, as shown in the attached pdf. Any suggestions for what I can do to fix this?

Thanks!

  1. \documentclass[man,11pt, a4paper]{apa6}
  2. \usepackage{filecontents}
  3. \begin{filecontents}{test.bib}
  4. @article{Smith1978,
  5. Author = {Smith, J.E.},
  6. Title = {A re-examination},
  7. Journal = {Objective Bulletin},
  8. Year = {1978},
  9. Volume = {85},
  10. Number = {3},
  11. Pages = {12-17}
  12. }
  13. \end{filecontents}
  14.  
  15. \usepackage[style=apa,sortcites=true, sorting=nyt, backend=biber]{biblatex}
  16. \usepackage{csquotes}
  17. \usepackage[american]{babel}
  18. \DeclareLanguageMapping{american}{american-apa}
  19. \addbibresource{test.bib}
  20. \author{JJ}
  21. \title{Test}
  22. \shorttitle{test}
  23. \begin{document}
  24. \maketitle
  25. Blah, blah \parencite{Smith1978}. Blah, blah, blah.
  26. \printbibliography
  27. \end{document}
Attachments
reftest.pdf
(45.65 KiB) Downloaded 208 times

Tags:

User avatar
Johannes_B
Site Moderator
Posts: 4163
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Wed Jul 03, 2013 5:35 pm

I just tested the code you are providing, i cannot reproduce the behaviour. The year is shown.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

stegzzz
Posts: 2
Joined: Wed Jul 03, 2013 5:15 pm

Postby stegzzz » Wed Jul 03, 2013 7:32 pm

Johannes_B wrote:I just tested the code you are providing, i cannot reproduce the behaviour. The year is shown.


hmm, I suppose that means there is something about my setup. There are no errors during the build but one clue is the

  1. \DeclareLanguageMapping{american}{american-apa}


statement that is highlighted in red in TeXstudio editor and shows 'unrecognized command' when I hover
Last edited by cgnieder on Wed Jul 03, 2013 9:59 pm, edited 1 time in total.
Reason: added code markup


Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 5 guests