LaTeX forum ⇒ BibTeX, biblatex and biberBibTeX References Counter Topic is solved

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
Posts: 2
Joined: Tue Feb 12, 2013 1:54 pm

BibTeX References Counter  Topic is solved

Postby duduspot » Tue Feb 12, 2013 2:14 pm

Hello guys!!

I'm using TexMakerX 2.1, MikTeX 2.9 and I'm writing a master thesis with one template that was given to me. I use BibTeX to make all references. I have two separate reference (Internet References and Literature).

The problem is that when I introduce some references to "Internet References" everything works fine but the number of reference starts with number [3]! It's wrong because I want to start from [0].

I will put the code of literature creation and prints of my LaTeX generated internet references:

  1. \newpage
  2. \renewcommand\bibname{Literature}
  4. %\setlength{\bibsep}{0.0pt}
  6. \addcontentsline{toc}{chapter}{Literature}
  7. \label{lit}
  8. \bibliography{literature}
  9. \bibliographystyle{alphadin}
  10. % the style of bibliography
  11. % start a new page
  13. \newpage
  14. \addcontentsline{toc}{chapter}{Internet References}
  15. \label{wlit}
  16. \bibliographyweblink{weblinks}
  17. \bibliographystyleweblink{abbrv}
  18. \newpage

And the result in the document is this:
Internet References

[3] D. Energy and T. Unit. Towards a secure, sustainable and competitive european energy
network. European Comission, August 2012.

[4] Eurostat.Electricity generated from renewable energy sources, EU-27, 2000-2010. European
Comission, August 2012.

[5] I. for Sustainable Growth Unit. ICT for a Low Carbon Economy - Smart Electricity Distri-bution Networks. European Comission, October 2012.

How can I reset that counter (the number between square brackets)? I can not find it anywhere in the code, so I suspect that is one type of internal counter.

Please help.
Last edited by localghost on Tue Feb 12, 2013 5:51 pm, edited 1 time in total.
Reason: Longer passages of source code are tagged as code block, not as in-line code.


Posts: 2
Joined: Tue Feb 12, 2013 1:54 pm

Postby duduspot » Tue Feb 12, 2013 6:18 pm

Hy guys! I made a mistake saying that m using bibtex. Im really using multibib and I just found a solution for my problem.

I had a package:

  1. \usepackage{multibib}

and I changed to this:

  1. \usepackage[resetlabels]{multibib}

It solved my problem. I found how to reset the internal counter Now the references counter starts in [1] :D

Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 2 guests