LaTeX forum ⇒ BibTeX, biblatex and biber@MISC wont show up on reference list Topic is solved

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
tbstensrud
Posts: 4
Joined: Mon Jan 28, 2013 5:05 pm

@MISC wont show up on reference list

Postby tbstensrud » Mon Jan 28, 2013 5:09 pm

I'm trying to add a URL to my reference list, but when I use this in the bib file

  1. @MISC{tek10,
  2. AUTHOR="Lovdata",
  3. TITLE="Teknisk forskrift 2010",
  4. YEAR="2010",
  5. URL="http://www.lovdata.no/cgi-wift/ldles?doc=/sf/sf/sf-20100326-0489.html"
  6. }


nothing shows up in my pdf file when i run it. I get no error messages. Other references do show up in the pdf file.
Last edited by cgnieder on Mon Jan 28, 2013 7:59 pm, edited 1 time in total.
Reason: added code markup

Tags:

User avatar
Stefan Kottwitz
Site Admin
Posts: 9504
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Mon Jan 28, 2013 5:25 pm

Hi,

welcome to the board!

Perhaps post a Infominimal working example, which shows the problem when we run it. Follow the link to learn why and how. It could be a compilable but drastically reduced copy of the problematic document and the bibliography. So we would also see the bibliography style and the settings. Otherwise it's hard to guess - BibTeX or biblatex, natbib or standard, which style, and more is unknown.

Stefan
Site admin

tbstensrud
Posts: 4
Joined: Mon Jan 28, 2013 5:05 pm

Postby tbstensrud » Mon Jan 28, 2013 6:13 pm

Ok. Examples are the bib file and the tex file. Also, somehow the order of the references are not correct.
Attachments
referanseliste.bib
(482 Bytes) Downloaded 452 times
example.tex
(719 Bytes) Downloaded 376 times

User avatar
Stefan Kottwitz
Site Admin
Posts: 9504
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Mon Jan 28, 2013 6:44 pm

In the attached referanseliste.bib there's a comma missing before the url. But the example in your first post is ok, so that's probably just another small typo.

The plain bibliography style ignores the url field. You need to use a style which supports it. For example, you could load natbib:

  1. \usepackage{natbib}


and later you specify plainnat, which is the natbib version of plain:

  1. \bibliographystyle{plainnat}


natbib provides also author-year styles, which are popular today.

Stefan
Site admin

tbstensrud
Posts: 4
Joined: Mon Jan 28, 2013 5:05 pm

Postby tbstensrud » Mon Jan 28, 2013 7:13 pm

I did as you said, however there are no url displaying yet. Also the order of references appears to be random. Ideally I want the references in the text to be labled 1,2,3 and so on regardless of their placement in the bib file.

I've looke at this site, http://merkel.zoneo.net/Latex/natbib.php, to find if there is a way to sort the references correctly, but I cant find it. Perhaps there are other packages who does this?

User avatar
Stefan Kottwitz
Site Admin
Posts: 9504
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Mon Jan 28, 2013 7:25 pm

tbstensrud wrote:I did as you said, however there are no url displaying yet.


It's displayed when I do as above. Perhaps you did something different, you could check again. Have a look at my output:

bibliography.png
bibliography.png (10.53 KiB) Viewed 8880 times


tbstensrud wrote:Also the order of references appears to be random. Ideally I want the references in the text to be labled 1,2,3 and so on regardless of their placement in the bib file.


Then perhaps use unsrt or unsrtnat instead.

  1. \bibliographystyle{unsrtnat}


Stefan
Site admin

tbstensrud
Posts: 4
Joined: Mon Jan 28, 2013 5:05 pm

Postby tbstensrud » Mon Jan 28, 2013 10:30 pm

The error with the URL was my mistake. I was certain I added the "," there in the bib file, but i seem to have forgotten it, so it works now.

As for the numbering, for now I'm going to leave it as it is and go for the (author year) option which works just fine. Thanks for all the help. Much obliged!


Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 15 guests