LaTeX forum ⇒ BibTeX, biblatex and biberBibliography Database corrupted by KBibTeX Topic is solved

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
Posts: 20
Joined: Tue Oct 07, 2008 6:56 pm

Bibliography Database corrupted by KBibTeX

Postby rawlins02 » Sat Oct 13, 2012 6:36 pm

The latest version of KBibTeX is giving me trouble.

  1. [12] [13] (./paper_2012.bbl
  2. ! Undefined control sequence.
  3. <argument> \Chapin
  4. et~al., 2005
  5. l.3 \bibitem[\Chapin et~al., 2005]{Chapin:05}
  7. ? ^C! Interruption.
  8. <argument> \Chapin
  9. et~al., 2005
  10. l.3 \bibitem[\Chapin et~al., 2005]{Chapin:05}

Seems that the newest version is adding slashes (\) into the elements of the reference in .bbl file, and my version of latex is not able to handle these. Those slashes were not part of the bbl reference created in the older version of KBibTeX. Prior to my using this newest version (0.4-1 on Ubuntu 12.04) I was using version 0.2.3-1 along with pdfTeX, Version 3.1415926 on Ubuntu Lucid. Seems these slashes are incompatible with this version of latex. Any ideas?


Site Moderator
Posts: 814
Joined: Tue Jul 01, 2008 2:19 pm

Postby josephwright » Sun Oct 14, 2012 11:18 am

We will need to see the content of your .bib file which generates this information. It looks like you have an odd entry for the author for this record.
Joseph Wright

Posts: 20
Joined: Tue Oct 07, 2008 6:56 pm

Postby rawlins02 » Sun Oct 14, 2012 3:39 pm

Here is that first one that appears in the .bbl file:

  1. @Article{Chapin:00,
  2. author = "\F. S. {\{Chapin {III}}} and \A. D. \McGuire and \J. \Randerson and \R. Pielke \{Sr} and \D. \Baldocchi and \S. E. \Hobbie and \N. \Roulet and \W. \Eugster and \E. \Kasischke and \E. B. \Rastetter and \S. A. \Zimov and \W. C. {\O}echel and \S. W. \Running",
  3. journal = GCB,
  4. pages = "5211--5223",
  5. title = "{Feedbacks from arctic and boreal ecosystems to climate}",
  6. volume = 6,
  7. year = 2000
  8. }

I believe the newest version of KBibTeX rewrote all of my .bib entries; in the past, no backslashes were present in the .bib entries. I'm wondering if this format (above), with the backslashes preceeding each last name, is incompatible with the version of latex I've been using for the pastr few years.

User avatar
Site Moderator
Posts: 9204
Joined: Fri Feb 02, 2007 12:06 pm

Postby localghost » Sun Oct 14, 2012 4:00 pm

I can't comprehend this problem. I used KBibTeX 0.4 to create the below bibliography database with the settings as shown in the attachment.
  1. @comment{x-kbibtex-personnameformatting=<%l><, %f><, %s>}
  3. @book{knuth84,
  4. author = {Knuth, Donald Ervin},
  5. publisher = {Addison-Wesley},
  6. title = {{The \TeX book}},
  7. year = {1984}
  8. }
  10. @book{lamport94,
  11. author = {Lamport, Leslie},
  12. edition = {Second},
  13. note = {User's Guide and Reference Manual},
  14. publisher = {Addison-Wesley},
  15. title = {{\LaTeX\ -- A Document Preparation System}},
  16. year = {1994}
  17. }
  19. @book{mitgoo04,
  20. author = {Mittelbach, Frank and Goossens, Michel},
  21. edition = {Second},
  22. publisher = {Addison-Wesley},
  23. title = {{The \LaTeX\ Companion}},
  24. year = {2004}
  25. }
  27. @book{goomit07,
  28. author = {Goossens, Michel and Mittelbach, Frank and Rahtz, Sebastian and Roegel, Denis and Voss, Herbert},
  29. edition = {Second},
  30. publisher = {Addison-Wesley},
  31. title = {{The \LaTeX\ Graphics Companion}},
  32. year = {2007}
  33. }

The settings dialogue appears when you want to save the database. By the way, there seems to be a missing checkbox for »Protect Casing«. Perhaps a bug.
The settings in KBibTeX 0.4 when saving a bibliography database.
KBiBTeX-Save-Settings.png (27.8 KiB) Viewed 4969 times
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes

¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

Posts: 20
Joined: Tue Oct 07, 2008 6:56 pm

Postby rawlins02 » Sun Oct 14, 2012 4:47 pm

I never saw that settings dialog appear when saving changes to the .bib database file. I installed this newest version of KBibTex about two weeks ago after installing Ubuntu 12.04. On first use I opened the .bib database (had been using the older KBibTex and everything had been fine), added a couple new entries, saved the file, and noticed the backslashes in the names.

I'll see if I can find the settings dialog and/or make a change which will save the database with a format without those pesky backslashes.


Posts: 20
Joined: Tue Oct 07, 2008 6:56 pm

Postby rawlins02 » Sun Oct 14, 2012 5:42 pm

I've located the Settings menu (at top of toolbar in Unity/Ubuntu 12.04). Selected "Configure KBibTex", then "BibTex" under "Saving and Exporting". I've set Person Names Formatting to Doe, John. Saved the file. I'm still seeing the backslashes before names. Should I expect no backslashes? If so, how do I configure?

Posts: 20
Joined: Tue Oct 07, 2008 6:56 pm

Postby rawlins02 » Mon Oct 15, 2012 3:13 am

Problem appears to be solved. :D

As a test I created a new entry and saved it to a new .bib file. When I chose "save as" the dialog came up for formatting. I'd previously set name format to Doe, John and that was preserved. After saving I see there are no backslashes in the saved .bib file. I assume that when I open my existing .bib database, modified it and then saved it, the default setting added backslashes before nearly all of the last names, first names, and initials. Guess that was the defualt. If so one might ask why were they causing a problem with latex. If I learn more I'll post again.

Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 4 guests