LaTeX forum ⇒ BibTeX, biblatex and biberProblem with aux file for .bib file

Information and discussion about BiBTeX - the bibliography tool for LaTeX documents.
tijh
Posts: 1
Joined: Tue Jul 17, 2012 12:25 am

Re: Problem with aux file for .bib file

Postby tijh » Tue Jul 17, 2012 1:37 am

I had struggled with the same problem today, and thanks to mariana's comment I found what was wrong - one of the files I had \included in my main document had an "extra" \end{document} at the bottom, causing LaTeX to miss the bibliography-lines in the code.

Also, I had generated the .tex file I wanted to include using Scrivener's MMD->LaTeX converter and not only did it include that pesky \end{document}, it had not automatically appended .tex into the file name - although the file was recognised as such by Textmate. Somehow the whole typesetting process, probably at the stage of the .aux file being created didn't work properly before changing the file name in Finder from filename to filename.tex.

Not sure if either would help anyone else, but I just wanted to thank mariana for the hint that helped me find what was wrong, and I'd agree that the problem can be elsewhere in the file, stopping the process to even reaching the bibliography code. In my case it was the included file terminating the document before the bib info was read. No wonder that BibTeX found nothing to chew.

Alek
Posts: 1
Joined: Wed Aug 08, 2012 4:49 pm

Postby Alek » Wed Aug 08, 2012 4:54 pm

I had the same problem running TexMaker and I found this solution:

Fist I updated to the latest version of TexMaker (now 3.4.1).
Then just add backend=bibtex in the biblatex package options:

  1. \usepackage[backend=bibtex,style=verbose-trad2,natbib=true]{biblatex}


that solved for me.

Hope it helps!

a
Last edited by Stefan Kottwitz on Wed Aug 08, 2012 5:47 pm, edited 1 time in total.
Reason: code marked

DaniR
Posts: 1
Joined: Tue Nov 12, 2013 7:18 am

Postby DaniR » Tue Nov 12, 2013 7:27 am

Embarrassed to admit I made an account for this, but um double check the name of your bibliography - cuz mine was wrong:
\bibliographystyle{Bibtype}
\bibliography{YourFile}
replace Bibtype and YourFile with the desired bib type and file name. If anybody else made this silly mistake, hopefully this helps!

arminkazim
Posts: 1
Joined: Sun Jul 31, 2016 10:52 am

Postby arminkazim » Sun Jul 31, 2016 10:59 am

For me the problem was related to the program not being able to access a file included in on of my tex codes.
After i regranted the accessability the aux file was created correctly with the bib style in it (by starting the pdflatex process of texmaker) and everything was great again.
Texmaker only showed an short error during the compiling process stating that an error occurred with the message "could not acccess file xxx".
This error wasnt shown in the overview after the process ended,
so i had a hard time figuring out that an error happened at all.

diegoArgentina
Posts: 2
Joined: Mon Aug 01, 2016 6:21 pm

Postby diegoArgentina » Mon Aug 01, 2016 6:33 pm

I had the same problem with the modern CV template

I get:

Process started
  1. This is BibTeX, Version 0.99d (MiKTeX 2.9) The top-level auxiliary file: CV Diego Rossit.aux I found no \citation commands---while reading file CV Diego Rossit.aux I found no \bibdata command---while reading file CV Diego Rossit.aux I found no \bibstyle command---while reading file CV Diego Rossit.aux (There were 3 error messages)
  2.  
  3. Process exited with error(s)

and the document is printed without any bibliography.
My .tex file is like the following:


  1. \documentclass[8pt,a4paper,sans]{moderncv} % Font sizes: 10, 11, or 12; paper sizes: a4paper, letterpaper, a5paper, legalpaper, executivepaper or landscape; font families: sans or roman
  2.  
  3. \moderncvstyle{casual} % CV theme - options include: 'casual' (default), 'classic', 'oldstyle' and 'banking'
  4. \moderncvcolor{blue} % CV color - options include: 'blue' (default), 'orange', 'green', 'red', 'purple', 'grey' and 'black'
  5. \usepackage{lipsum} % Used for inserting dummy 'Lorem ipsum' text into the template
  6. \usepackage{lmodern}
  7.  
  8. \usepackage[scale=0.85]{geometry} % Reduce document margins
  9.  
  10. [i][i]\usepackage[backend=biber,
  11. style=numeric, %sorting=ynt,
  12. sorting = none,
  13. maxbibnames=99, defernumbers=true, isbn = true]{biblatex}
  14. \addbibresource{articles.bib}
  15. \addbibresource{proceedings.bib}
  16. \addbibresource{incollection.bib}
  17. \defbibheading{bibliography}{}
  18.  
  19. \setlength{\hintscolumnwidth}{3.5cm} % Uncomment to change the width of the dates column
  20.  
  21. \begin{document}
  22.  
  23. \section{Reuniones cient\'{i}ficas: trabajos y res\'{u}menes publicados}
  24.  
  25. \nocite{*}
  26. \printbibliography[resetnumbers=true,type=inproceedings]
  27.  
  28. \section{Partes de libros}
  29.  
  30. \nocite{*}
  31. \printbibliography[resetnumbers=true,type=incollection]
  32.  
  33. \section{Art\'{i}culos de revista}
  34.  
  35. \nocite{*}
  36. \printbibliography[resetnumbers=true,type=article]
  37.  
  38. \end{document}


Thanks in advance for any clue that you could suggest.
Regards!

User avatar
Johannes_B
Site Moderator
Posts: 4044
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Mon Aug 01, 2016 7:12 pm

You have to use the extra program biber, but you are using the extra program bibtex. Please have a look at Biblatex with Biber.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

diegoArgentina
Posts: 2
Joined: Mon Aug 01, 2016 6:21 pm

Postby diegoArgentina » Wed Oct 09, 2019 1:33 am

Solved! Thank you very much.


Return to “BibTeX, biblatex and biber”

Who is online

Users browsing this forum: No registered users and 7 guests