LaTeX forum ⇒ General"Command \@xhline has changed"

LaTeX specific issues not fitting into one of the other forums of this category.
Posts: 20
Joined: Thu Nov 16, 2017 2:43 pm

"Command \@xhline has changed"

Postby fhrttn » Mon May 11, 2020 10:12 pm

I have changed my pc and installed full package of latex "texlive-full". But when I ran the code I got the error as follows
Code: [Select all] [Expand/Collapse] [Download] ({untitled.tex})
  1. Command \@xhline has changed.

Here is the first part of the tex file

Code: [Select all] [Expand/Collapse] [Download] ({untitled.tex})
  1. \documentclass[12pt]{iopart}
  2. \usepackage{iopams}
  3. \usepackage{graphicx}
  4. \usepackage{graphics}
  5. \usepackage{subfigure}
  6. \usepackage{multirow}
  7. %\usepackage[
  8. %singlelinecheck=false % <-- important
  9. %]{caption}
  10. \DeclareMathAlphabet\mathbfcal{OMS}{cmsy}{b}{n}
  11. \usepackage{booktabs}
  12. \usepackage{cite}
  13. \usepackage{longtable}
  14. \usepackage{pdflscape}
  15. \usepackage{graphicx}
  16. \usepackage{floatrow}
  17. \floatsetup[longtable]{LTcapwidth=table}
  18. \usepackage{array}
  19. \newsavebox\dummy
  20. \newcolumntype{H}{>{\begin{lrbox}{\dummy}}c<{\end{lrbox}}@{}}

This tex file is working on my old pc. What is the problem ?

Posts: 281
Joined: Sun Nov 16, 2014 8:51 pm

Postby rais » Tue May 12, 2020 9:46 pm

\@xhline is defined by the LaTeX kernel and checked by the array package (before it tries to redefine it), AFAIK.

You could try to load it earlier (to see if one of the other packages you're loading is redefining \@xhline), and you could try one of the standard classes.
If you get the same error with
Code: [Select all] [Expand/Collapse] [Download] ({untitled.tex})
  1. \documentclass{article}
  2. \usepackage{array}
  3. \begin{document}
  4. \end{document}

please show us the log file of running that.


Return to “General”

Who is online

Users browsing this forum: No registered users and 7 guests