LaTeX forum ⇒ Generalbabel UKenglish Topic is solved

LaTeX specific issues not fitting into one of the other forums of this category.
trewornan
Posts: 2
Joined: Thu Nov 07, 2019 9:08 pm

babel UKenglish

Postby trewornan » Thu Nov 07, 2019 9:54 pm

Hi everyone, new member here!

Been trying to learn Latex for about a week now - seem to be getting along OK and feel I've reached the stage of checking I'm doing things the right way.

Discovered a list of "deadly sins" and one of the things it recommended was using KOMA-script classes for A4 formatting which is working well. That started me thinking (dangerous) so I looked into other differences to the US and thought I ought to use the babel package:

\usepackage[UKenglish]{babel}
or
\usepackage[british]{babel}

Yeah, I forgot to say I'm in the UK.

Anyway, I'm getting the following error for both:

! Package babel Error: Unknown language `english'. Either you have
(babel) misspelled its name, it has not been installed,
(babel) or you requested it in a previous run. Fix its name,
(babel) install it or just rerun the file, respectively.

Confusingly using the "[english]" option does work?

So I ran a search on /usr/share/texmf and there don't seem to be any files with english or british in the filename but I get the impression that's not necessarily wrong and it might be part of something else. Searching the web hasn't produced very much of use regarding how to check packages are installed. Any suggestions?

Also (and less seriously) I'm getting a warning about using the "parskip" package with KOMA-script classes. I'm not sure how seriously to take compiler warnings in latex - particularly since so far it hasn't caused me any problems. Also I saw some advice saying not to change the value of parskip but to use the parskip package instead now I'm getting a warning saying the reverse.

User avatar
Johannes_B
Site Moderator
Posts: 4077
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Fri Nov 08, 2019 7:22 am

Hi and welcome to the forum.
The error message from babel is completely normal, when changing the document language. It shouldn't change often in the real document, right?
Ignore the error message and it will be gone with the next compile run.


Concerning the parskip package, you don't need it. KOMA-script offers its own implementation. You should use parskip=true in the document class options. Please see the manual for the full list of options.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

trewornan
Posts: 2
Joined: Thu Nov 07, 2019 9:08 pm

Postby trewornan » Fri Nov 08, 2019 12:33 pm

That's excellent, thanks very much Johannes.


Return to “General”

Who is online

Users browsing this forum: MSN [Bot] and 4 guests