LaTeX forum ⇒ GeneralRequested Package Not Available Topic is solved

LaTeX specific issues not fitting into one of the other forums of this category.
Cottonshirt
Posts: 4
Joined: Thu Nov 10, 2016 11:04 pm

Requested Package Not Available

Postby Cottonshirt » Tue Nov 15, 2016 2:11 pm

Good morning,

I am using MikTex 2.9 in TexWorks version 0.4.4 r.1003

I wanted to put a genealogy tree into a Latex document and googling for solutions one suggestion was a package called forest.

my package manager didn't have that so I selected: repository -> synchronize and it went to work.

next step: in the list view I selected package forest and clicked the tick and it installed forest and a couple of other packages too. in fact, all of the following: unicode-data, l3kernel, l3packages, trimspaces, environ, elocalloc, elpres, etoolbox, pgfopts, and forest.

next step: in my document template I added forest to the \usepackage{} list. I didn't put anything in the document itself, just added forest to the package list. then I compiled the document.

I got a number of messages telling me the package manager wanted to do something and I just clicked install each time (around 3 times if I remember correctly).

then I got the following in the console area at the bottom of the screen:

  1. ("C:\Documents and Settings\User\Application Data\MiKTeX\2.9\tex\latex\elocallo
  2. c\elocalloc.sty") (C:\programs\miktex\tex\latex\environ\environ.sty
  3. (C:\programs\miktex\tex\latex\trimspaces\trimspaces.sty))
  4. (C:\programs\miktex\tex\latex\l3packages\xparse\xparse.sty
  5. (C:\programs\miktex\tex\latex\l3kernel\expl3.sty
  6. (C:\programs\miktex\tex\latex\l3kernel\expl3-code.tex)
  7. (C:\programs\miktex\tex\latex\l3kernel\l3pdfmode.def)))
  8. ! Illegal parameter number in definition of \pgfk@/handlers/.wrap 6 pgfmath arg
  9. s/.@@body.
  10. <to be read again>
  11. 7
  12. l.1946 }



In the "Errors" tab it said the following:
LaTeX Warning: You have requested, on input line 49, version`2013/12/13' of package tikz, but only version `2010/10/13 v2.10 (rcs-revision 1.76)' is available.

there's a hyperlink you can click on to show the code where it failed and it gives this:

\RequirePackage{tikz}[2013/12/13]

where my rudimentary code-reading skills say that the file forest.sty is specifying package tikz dated 2013/12/13

thing is, there is not just one package called tikz, there's about twenty of them: tikzthis and tikzthat and what have you so I just used the package manager to install them all and I still get the same error.

I'm not sure it will help much, but I attach an MWE anyway.

  1. \documentclass[10pt,a4paper]{book}
  2. \pagestyle{empty}
  3.  
  4. \usepackage[utf8]{inputenc}
  5. \usepackage{endnotes,forest}
  6.  
  7. \begin{document}
  8. some text goes here
  9.  
  10. \end{document}


does anyone have any idea what's going wrong and what I need to do next?


many thanks for your consideration.

Tags:

User avatar
Stefan Kottwitz
Site Admin
Posts: 8955
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Tue Nov 15, 2016 2:14 pm

TikZ is part of the pgf package. So look in your package manager for the "pgf" package and update it.

Stefan
Site admin

Cottonshirt
Posts: 4
Joined: Thu Nov 10, 2016 11:04 pm

Postby Cottonshirt » Thu Nov 17, 2016 5:47 am

it turns out that "synchronize" doesn't do what I thought it did.

the clue was when you said, "update it." thanks for your help, appreciate it.

Hiseeno
Posts: 1
Joined: Tue Nov 29, 2016 11:29 pm

Postby Hiseeno » Tue Nov 29, 2016 11:31 pm

thanks Stefan very much. I was having similar problem and you got me the solution :)


Return to “General”

Who is online

Users browsing this forum: No registered users and 16 guests