LaTeX forum ⇒ GeneralBibliography

LaTeX specific issues not fitting into one of the other forums of this category.
layuval
Posts: 19
Joined: Thu Aug 18, 2016 11:37 pm

Bibliography

Postby layuval » Sat Sep 17, 2016 3:27 pm

Hello everyone,
From some reason Latex is stuck every time I'm trying to produce bibliography.
After hours of working I seek for your help
I have attached the bib file and the tex file.

Thanks for all the help!
Attachments
Untitled.tex
(468 Bytes) Downloaded 48 times
Example.bib
(450 Bytes) Downloaded 43 times

User avatar
Johannes_B
Site Moderator
Posts: 3853
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Sat Sep 17, 2016 6:06 pm

If you are writing a scientific report, it is (much) better to use the modern combo of bilatex and biber.

In your example, you are using a file extension for the name of the database. Since BibTeX can only handle one kind of database, the ending is omitted and it is assumed that the ending is bib, hence a bibtex database.

On the other hand, you are using a bibliographystyle that is called natbib. A package is called that name, but no bib-style. You have to use a bibstyle that actually exists.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

layuval
Posts: 19
Joined: Thu Aug 18, 2016 11:37 pm

Postby layuval » Sat Sep 17, 2016 11:26 pm

Thanks but I cannot fine any biter for Mac.
Any suggestions?

layuval
Posts: 19
Joined: Thu Aug 18, 2016 11:37 pm

Postby layuval » Sun Sep 18, 2016 1:26 am

One thing to note is that I'm using Texshop.

User avatar
Johannes_B
Site Moderator
Posts: 3853
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Sun Sep 18, 2016 6:20 am

Use \bibliographystyle{plain} or start from scratch, i don t really have any clue what you want to do.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

layuval
Posts: 19
Joined: Thu Aug 18, 2016 11:37 pm

Postby layuval » Sun Sep 18, 2016 8:01 am

I'm trying to have a list of reference for an article.

User avatar
Johannes_B
Site Moderator
Posts: 3853
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Sun Sep 18, 2016 8:45 am

I understand that. In your initial post you state that the code is failing for some strange reason, as if it would have worked before. But it never would have worked, since there is no valent bibliographystyle given. Package cite should not be used with package natbib (see warning). You haven't given any indication if you have removed the file extension, you did not say if plain worked (it won't). Try apacite instead, that will give you references in apa-style. I assume that this is what you want.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.


Return to “General”

Who is online

Users browsing this forum: No registered users and 11 guests