LaTeX forum ⇒ GeneralBabel not recognising english

LaTeX specific issues not fitting into one of the other forums of this category.
jose_iparraguirre
Posts: 1
Joined: Sun Dec 27, 2015 3:55 pm

Babel not recognising english

Postby jose_iparraguirre » Sun Dec 27, 2015 4:41 pm

Hi everyone,

I've just joined the forum because I've been struggling with babel not recognising English.

I've done my previous homework and looked at previous posts and on the web in general, but to no avail.

I've just downloaded and installed latex again (via Miktex) and downloaded TexLive too. I've also updated all the packages. I'm using Windows 10.

Even the following minimal document would not compile:
  1. \documentclass{article}
  2. \usepackage[english]{babel}
  3. \begin{document}
  4. Hello
  5. \end{document}

When I want to compile it, a MikTex Error Report window opens up with the message "Unknwn package" and in the Data window below "babel-English". If I click OK, a Package Installation windows opens up telling me that "the required file tex\latex\babel-english\english.ldf is missing. It is part of the following package: babel-English". If I click on Install, I get the following errors:

Package babel Error: Unknown option `english'. Either you misspelled itd. \ProcessOptions*
Package babel Error: You haven't specified a language option. ...ry to proceed from here, type x to quit.}

I've tried compiling the document with PdfLaTex, LuaLaTex, etc. Nothing.
Before attempting anything new, I've always deleted the aux file and tried again. Nothing.
I've changed to \usepackage[american]{babel}. Nothing.

How can I make this work?

Thanks,

Jose Iparraguirre

Tags:

User avatar
Johannes_B
Site Moderator
Posts: 4044
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Sun Dec 27, 2015 5:07 pm

Welcome,

you installed two different distributions that do exactly the same, providing a working LaTeX environment.

I am not sure if there are currently any problems with MikTeX, but i think english should be considered as base.
You could uninstall MikTeX and just use TeX Live, which usually is installed completely and should not miss any files.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.


Return to “General”

Who is online

Users browsing this forum: No registered users and 7 guests