LaTeX forum ⇒ GeneralI requested the wrong release of LaTeX Topic is solved

LaTeX specific issues not fitting into one of the other forums of this category.
Singularity
Posts: 155
Joined: Sat Jan 22, 2011 9:55 pm

I requested the wrong release of LaTeX

Postby Singularity » Sat Sep 05, 2015 2:13 am

Recently I have been getting the following error

LaTeX Warning: You have requested release `2014/05/01' of LaTeX,
but only release `2011/06/27' is available.


I think it has something to do with package lastpage. How can I get rid of it?

Here's the smallest MWE I could make.

  1. \documentclass[14pt,fleqn]{extarticle}
  2. \usepackage{lastpage}
  3.  
  4. % For PDF clickable links - LOAD THIS PACKAGE LAST (note: hidelinks does not work)
  5. \usepackage[pdfstartview=FitH,breaklinks,pageanchor,plainpages,backref=section,hyperindex,bookmarksnumbered,
  6. %pdfstartpage=7,
  7. bookmarksopen,bookmarksopenlevel=1]{hyperref}
  8. \hypersetup{pdfpagemode=UseNone}
  9.  
  10.  
  11. \begin{document}
  12.  
  13. \end{document}


MWE.tex
(417 Bytes) Downloaded 226 times

MWE.log
(11.35 KiB) Downloaded 233 times
Last edited by cgnieder on Sat Sep 05, 2015 12:33 pm, edited 1 time in total.
Reason: added code of MWE to post

Tags:

User avatar
Johannes_B
Site Moderator
Posts: 4078
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Sat Sep 05, 2015 1:12 pm

The reason and solution is quite simple: LaTeX is developed acticely, the base kernel as well as contribution packages. Package lastpage requires a newer version of the kernel than is available. Updating our complete TeX environment will get rid of the message.

Beware: Changing such basic stuff can change the output to unexpected results. Over the last years, even the TeX core (underneath LaTeX) has been updated by Knuth.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

Singularity
Posts: 155
Joined: Sat Jan 22, 2011 9:55 pm

Postby Singularity » Sat Sep 05, 2015 5:53 pm

I use MikTex and had to run the Update (Admin) process twice, but it worked.


Return to “General”

Who is online

Users browsing this forum: No registered users and 17 guests