LaTeX forum ⇒ GeneralTexnicCenter 2.02 64bit shows Russian text as garbage

LaTeX specific issues not fitting into one of the other forums of this category.
iliafine
Posts: 4
Joined: Tue Aug 04, 2015 11:45 am

TexnicCenter 2.02 64bit shows Russian text as garbage

Postby iliafine » Tue Aug 04, 2015 12:18 pm

I've successfully used a previous version of TexnicCenter with my Latex document in Russian language. But after installing a recent 2.02 64bit version on new computer, the same document is shown as garbage, although produces a pretty good PDF. At the same time this document is shown correctly by TeXworks editor.

Attempt to set Tools/Options/Text Format/Choose Font/Script=Cyrillic does not help.

Please, help.

Tags:

User avatar
Stefan Kottwitz
Site Admin
Posts: 8954
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Wed Sep 09, 2015 3:15 pm

Hi iliafine,

welcome to the forum!

I guess you already solved the problem. Or do you keep using TeXworks now? This is my favorite editor btw.

I think in TeXnicCenter it's an input encoding issue. You need to use the same encoding as with the previous version of TeXnicCenter. Otherwise you could open it in TeXnicCenter but specify the encoding type while opening.

Stefan
Site admin

iliafine
Posts: 4
Joined: Tue Aug 04, 2015 11:45 am

Postby iliafine » Wed Sep 09, 2015 3:49 pm

Hi Stefan,

Very thanks for reply. Unfortunately, I didn't find a solution and forced to use the old version of TexnicCenter, where the problem does not happen. I also have no intention to deeply study numerous features of TexnicCenter. I need it only as a tool for writing my article, no more. I have too much things to study besides that.

I didn't quite understand your advice, and would be very grateful if you can clarify it in some simple terms.

Regards,
Ilia.

User avatar
Stefan Kottwitz
Site Admin
Posts: 8954
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Wed Sep 09, 2015 4:11 pm

Hi Ilia!

Text files have a certain encoding. It it like matching numbers to characters. No issue usually with normal characters A ... Z and a... z, but for special characters like ä, ü, and ö. The input encoding can differ between operating systems (Windows, Mac, Unix) and between editors. Modern editors and systems use UTF-8, oder Windows editors may use latin1 or ansinew or cp-1252 or such. Maybe you would find such a setting in your editor configuration.

Well, especially Russian characters need a certain encoding. If you would update the editor, I would check the input encoding settings (don't know where it is in TeXnicCenter) and configure the very same settings in the new version too.

But as you said, the TeXnicCenter editor is a tool for writing. No need to make a science of it. :-) Maybe my explanation is just good to know for a future update, if it's too difficult now. An older TeXnicCenter version works fine too. Especially, it's just the editor: the oldest editor works fine with the newest version of TeX, so actually it's not urgent to update, generally.

Stefan
Site admin

iliafine
Posts: 4
Joined: Tue Aug 04, 2015 11:45 am

Postby iliafine » Wed Sep 09, 2015 4:55 pm

Hi Stefan,

Yes, my article starts with two commands

  1. \usepackage[cp1251]{inputenc}
  2. \usepackage[T2A]{fontenc}


which I guess are for encoding, and which are good for old TeXnicCenter and for TexWorks editor, but not for the new TeXnicCenter. I think also there should be some default settings which are used by editor before it opens and reads text file. In the old TeXnicCenter it was sufficient to set

Tools/Options/Text Format/Choose Font/Script=Cyrillic,

but it does not work in the new version.

Ilia.

User avatar
Stefan Kottwitz
Site Admin
Posts: 8954
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Wed Sep 09, 2015 5:39 pm

Yes, the first one is for input encoding. The second line is for output (font) encoding, no need to change.

Just a remark, encoding of files can be changed, such as with the iconv tool. Easy on Linux and Mac, but I don't know how tu run it on Windows. On my system I would call it as

iconv -f cp1251 -t utf8 filename.tex >newfilename.tex

and have it in modern UTF-8. Also this, take it as a remark, maybe it's not worth the effort.

Btw. I used to write cyrillic like this:

  1. \documentclass{article}
  2. \usepackage[T2A]{fontenc}
  3. \usepackage[utf8]{inputenc}
  4. \usepackage[russian]{babel}
  5. \begin{document}
  6. Это вводный абзац.
  7.  
  8. Это формула:
  9. \[
  10. y = x^2 + 1
  11. \]
  12. \end{document}


Stefan
Site admin

User avatar
Johannes_B
Site Moderator
Posts: 3795
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Wed Sep 09, 2015 6:07 pm

Please remember to make a backup on a usb drive first and put that in a save spot. Better save than sorry ;-)
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.


Return to “General”

Who is online

Users browsing this forum: No registered users and 5 guests