LaTeX forum ⇒ GeneralPolyglossia: spacing before footnotemark in running text

LaTeX specific issues not fitting into one of the other forums of this category.
KO-the-typo
Posts: 2
Joined: Thu Apr 23, 2015 10:55 am

Polyglossia: spacing before footnotemark in running text

Postby KO-the-typo » Thu Apr 23, 2015 11:35 am

Hi there,

I'm using Polyglossia with Lualatex for french documents, and it seems the spacing before footnotemark in running text is quite thin (it's a thinspace I would say).

It must quite a common question, so I looked inside the manual, on the forum and over the Web, but I haven't been able to find anything about it. Perhaps Am I missing a good keyword? Anyway, here's my MWE:

  1. % compile with Lualatex
  2. \documentclass[a5paper]{scrbook}
  3.  
  4. % Use one of the following lines:
  5. % \usepackage[french]{babel}
  6. \usepackage{polyglossia} \setmainlanguage{french}
  7.  
  8. \begin{document}
  9.  
  10. \Huge
  11. Magnifique\footnote{Prima!}!
  12.  
  13. \end{document}


If you run one time with Babel, and another one with Polyglossia, you will see the difference. So here's my question: what's the trick to change this spacing with Polyglossia, in order to get it two times larger, for example?

Many thanks,

KO

Tags:

User avatar
Johannes_B
Site Moderator
Posts: 4121
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Thu Apr 23, 2015 6:34 pm

Hi and welcome,

by a first glance, i wasn't able to see where a space could be introduced. There are other unresolved issues with polyglossia and french, i added this particular item to the list.

Hopefully, the author has some more time for this project in the future.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

KO-the-typo
Posts: 2
Joined: Thu Apr 23, 2015 10:55 am

Postby KO-the-typo » Fri Apr 24, 2015 8:22 am

Hi and thanks,

For now, I'm using the package FNPCT, which does the kern by itself, among others features. The current version on CTAN (0.4c) is not working with french Polyglossia, but I reported it to the author, who updated it to 0.4d, which is now working.

Perhaps it's a like using a sledgehammer for a nail, but it works.

  1. % compile with Lualatex
  2. \documentclass[a5paper]{scrbook}
  3.  
  4. \usepackage{polyglossia} \setmainlanguage{french}
  5. \usepackage{fnpct}
  6. \usepackage{hyperref} %after, not before fnpct
  7. \begin{document}
  8.  
  9. \Huge
  10. Magnifique\footnote{Prima!}!
  11.  
  12. \end{document}

User avatar
Stefan Kottwitz
Site Admin
Posts: 9557
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Fri Apr 24, 2015 9:53 am

Hi KO,

welcome to the forum!

Thank you for visiting again to tell us the solution, it may also be helpful for the next reader who comes in via google to search for the same problem.

Stefan
LaTeX.org admin


Return to “General”

Who is online

Users browsing this forum: No registered users and 3 guests