LaTeX forum ⇒ GeneralPackage{authblk} and command \affil

LaTeX specific issues not fitting into one of the other forums of this category.
akcays
Posts: 1
Joined: Fri Jul 18, 2014 2:58 pm

Package{authblk} and command \affil

Postby akcays » Fri Jul 18, 2014 3:00 pm

I seem to have a problem with the package {authblk} on my Ubuntu 10 machine. When I use the command \affil, LaTeX tells me that it's already been defined elsewhere, but if I use \affil without the package{authblk} then LaTeX simply does not recognize the command \affil and calls it an undefined control sequence. Any ideas as to what may be causing it?

Tags:

User avatar
Johannes_B
Site Moderator
Posts: 4044
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Fri Jul 18, 2014 11:36 pm

Revtex defines a similar command, the responing counter clashes with package authblk.

  1. %\documentclass{revtex4-1}
  2. \documentclass{article}
  3. \usepackage{authblk}
  4. \usepackage{blindtext}
  5. \begin{document}
  6. \author{Akcays}
  7. \affil{\LaTeX-community.org}%JB: authblk
  8. %\affiliation{\LaTeX-community.org}%JB: revtex
  9. \author{Johannes B}
  10. \affil{\TeX Welt}%JB: authblk
  11. %\affiliation{\TeX Welt}%JB: revtex
  12. \title{MWE}
  13. \maketitle
  14. \blinddocument
  15. \end{document}


BTW: please always prepare a minimal working example just as i did above. You mentioned revtex in the tags, that was the only hint i had. Having all the information needed is much better than hunt for them. And it makes helping so much easier and faster.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.


Return to “General”

Who is online

Users browsing this forum: No registered users and 9 guests