LaTeX forum ⇒ GeneralIEEE PDF eXpress errors

LaTeX specific issues not fitting into one of the other forums of this category.
Posts: 20
Joined: Wed Dec 22, 2010 10:21 pm

IEEE PDF eXpress errors

Postby john_latex » Tue Jan 04, 2011 9:49 am

I received the following errors from IEEE PDF eXpress.

* Font Helvetica-Bold is not embedded (34x)
* Font Helvetica-BoldOblique is not embedded
* Font Helvetica is not embedded (205x)
* Font Times-Bold is not embedded (2x)
* Font Helvetica-Oblique is not embedded (4x)
* Font Times-Roman is not embedded (3x)

I read some suggestions for .ps format.
latex file.tex
bibtex file
latex file.tex
latex file.tex
dvips -Ppdf -G0 -tletter file.dvi
ps2pdf -dCompatibilityLevel=1.4 -dPDFSETTINGS=/prepress file.pdf

Since, I have PDF images, I can't use those codes. Is there an alternative that passes IEEE PDF eXpress with no errors. Please suggest.
Last edited by john_latex on Wed Jan 12, 2011 8:09 pm, edited 1 time in total.

Recommended reading 2021: • •

Exclusive June 2024 offer: All LaTeX eBooks (PDF, EPBUB) for $9.99 or €8.99

LaTeX books

User avatar
Posts: 2064
Joined: Fri Mar 06, 2009 12:20 am

IEEE PDF eXpress errors

Postby frabjous » Tue Jan 04, 2011 5:44 pm

If you're using pdflatex, it typically embeds all fonts it uses. My guess is that the fonts are missing from the pdf images/figures that you're including, and if they're not embedded in those files, they won't be embedded in the PDF output either.

If possible, go back to the software you used to create these PDFs and see if that software has an option for embedding the fonts when it exports to PDF.

IF that's not possible, then one possible way might be to convert your final output to .ps and then back again using ghostscript, as suggested at the bottom of this page.

pdftops yourfile.pdf
ps2pdf14 -dPDFSETTINGS=/prepress

I have not tried that. I actually also think you can call ps2pdf14 directly on the pdf file, despite its name:

ps2pdf14 -dPDFSETTINGS=/prepress yourfile.pdf yourfile-output.pdf

Some other suggestions here.

Posts: 20
Joined: Wed Dec 22, 2010 10:21 pm

IEEE PDF eXpress errors

Postby john_latex » Wed Jan 05, 2011 7:10 am

Thanks frabjous. Your suggestions are helpful. Based on your suggestions, I tried
pdflatex yourfile.tex
pdftops yourfile.pdf
ps2pdf14 -dPDFSETTINGS=/prepress yourfile.pdf yourfile-output.pdf

The yourfile-output.pdf file was compatible with IEEE express. Thank you so much frabjous for replying to each of my posts.

User avatar
Site Moderator
Posts: 9201
Joined: Fri Feb 02, 2007 12:06 pm

IEEE PDF eXpress errors

Postby localghost » Wed Jan 12, 2011 6:57 pm

Now that the problem is solved, please be so kind and mark the topic (not the last post) accordingly as clearly written in the Board Rules (to be read before posting). Please keep that in mind for the future so that further reminders will not be necessary.

LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes

¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

Return to “General”

Who is online

Users browsing this forum: No registered users and 50 guests