LaTeX forum ⇒ GeneralProblem with linking LaTeX and Mendeley

LaTeX specific issues not fitting into one of the other forums of this category.
Physopholy
Posts: 1
Joined: Thu Nov 01, 2018 11:04 pm

Problem with linking LaTeX and Mendeley

Postby Physopholy » Thu Nov 01, 2018 11:29 pm

Hey guys, I'm attempting to get LaTeX setup with Mendeley as my .bib generator. I'm using TexLive with TexMaker. I've gotten almost everything working, but I'm having trouble getting LaTeX to look in the folder where I'm having Mendeley put my .bib files. I can take the .bib file and put it in the same folder as my main document file and then it works. I've been following[this][https://simonduerr.eu/blog/mendeley-latex-texmaker-setup-tutorial/] guide from 2016. He says to put "biber --input-directory='C:/Users/Simon/Dropbox/BibTex/' build/%" in for the Bib(La)Tex configure line, obviously with the file tree being your's and not the one for his file. Does "build/%" mean to put the file tree where your LaTeX files are stored and % looks for the current file? That's what I had to put for it to pickup the bib file when I put it in that folder, so I assume so. My main question is why doesn't it properly at the mendeley folder to my search path? Here's the error message:

INFO - This is Biber 2.11 INFO - Logfile is 'C:/Users/Sean/Desktop/LaTex_Lessons/Test01.blg' INFO - Reading 'C:/Users/Sean/Desktop/LaTex_Lessons/Test01.bcf' INFO - Found 1 citekeys in bib section 0 INFO - Processing section 0 INFO - Looking for bibtex format file 'Test.bib' for section 0

ERROR - Cannot find 'Test.bib'! INFO - ERRORS: 1

Here's the relevant section of code from my file:

\usepackage[style=ieee]{biblatex}

\addbibresource{Test.bib}

Do I need to change the argument on the addbibresource command? Kind of a programming noob, here. To reiterate, it works if I copy the .bib file from the mendeley target directory.

Return to “General”

Who is online

Users browsing this forum: No registered users and 11 guests