LaTeX forum ⇒ Fonts & Character SetsInstalling a font

Information and discussion about fonts and character sets (e.g. how to use language specific characters)
bertibott
Posts: 14
Joined: Wed Dec 12, 2018 3:32 pm

Installing a font

Postby bertibott » Sun Feb 17, 2019 1:36 pm

Okay... progress!
I installed xzdec.
After that I ran

sudo tlmgr init-usertree


and got:
  1. (running on Debian, switching to user mode!)
  2. tlmgr: user mode database already set up in
  3. tlmgr: /home/bertibott/texmf/tlpkg/texlive.tlpdb
  4. tlmgr: not overwriting it.


After that I ran

sudo tlmgr install aurical

And got this:

  1. (running on Debian, switching to user mode!)
  2. tlmgr: Remote repository is newer than local (2017 < 2018)
  3. Cross release updates are only supported with
  4. update-tlmgr-latest(.sh/.exe) --update
  5. Please see <!-- m --><a class="postlink" href="https://tug.org/texlive/upgrade.html">https://tug.org/texlive/upgrade.html</a><!-- m --> for details.



So... I understand that something is outdated... Is it the version of tlmgr? Or the repository holding the aurical package?
And how do I update it?

User avatar
Stefan Kottwitz
Site Admin
Posts: 9323
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Sun Feb 17, 2019 3:15 pm

It seems that you don't use TeX Live 2018 but the 2017 version. Online updates/installations are only possible with the current version, that's 2018. Verify that it's 2018 or install 2018. Perhaps it could work anyway if you run

sh update-tlmgr-latest.sh -- --upgrade

at the directory where that .sh script is, probably in /usr/local/texlive/2017. Or

sh /usr/local/texlive/2017/update-tlmgr-latest.sh -- --upgrade

or

sh /usr/local/texlive/2018/update-tlmgr-latest.sh -- --upgrade

Stefan
Site admin

bertibott
Posts: 14
Joined: Wed Dec 12, 2018 3:32 pm

Postby bertibott » Sat Feb 23, 2019 11:18 am

this all confuses me greatly...
I can't really seem to get anywhere... how do I figure out what latex versions are installed? and which one is being used?

Or how do I get rid of all of them so I can make a clean start? I realize this is more of a linux question and less a latex specific one...


Return to “Fonts & Character Sets”

Who is online

Users browsing this forum: No registered users and 2 guests