LaTeX forum ⇒ Math & Scienceapparent tilde/breve bug in amsmath

Information and discussion about LaTeX's math and science related features (e.g. formulas, graphs).
ngrube
Posts: 2
Joined: Sun Oct 02, 2011 10:30 pm

apparent tilde/breve bug in amsmath

Postby ngrube » Sun Oct 02, 2011 10:58 pm

Hi,

I have encountered what appears to be a bug in the amsmath package related to nested tildes and/or breves. I would be grateful for suggestions on where to report this and/or on workarounds. I already sent an email to a tech support address at AMS, but I was not certain whether that was the right thing to do. This is my first attempt at reporting a bug.

An minimum working example follows. The error is that the j from the first equation is somehow remembered and shows up unexpectedly in the second and third equations. If I comment out the amsmath package, then it works correctly.

Thanks,
Nathan Grube

  1. \documentclass[11pt]{article}
  2. \usepackage{geometry}
  3. \geometry{letterpaper}
  4. \usepackage[]{amsmath}
  5. \begin{document}
  6.  
  7. \begin{equation}
  8. \breve{\tilde{j}}
  9. \end{equation}
  10.  
  11. \begin{equation}
  12. \breve{\breve{{T}} \breve{{v}}}
  13. \end{equation}
  14. \begin{equation}
  15. \tilde{{\tilde{T}} {\tilde{v}}}
  16. \end{equation}
  17.  
  18. \end{document}
Last edited by Stefan Kottwitz on Sun Oct 02, 2011 11:42 pm, edited 1 time in total.

Tags:

User avatar
Stefan Kottwitz
Site Admin
Posts: 9436
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Sun Oct 02, 2011 11:41 pm

Hi Nathan,

that's interesting!

Here's a quick workaround: use

  1. \smash{\vphantom{$\breve{}$}}

or probably better

  1. \makeatletter
  2. \global\let\macc@nucleus\@empty
  3. \makeatother


before the next equation which showed that problem.

Stefan
Site admin

ngrube
Posts: 2
Joined: Sun Oct 02, 2011 10:30 pm

Postby ngrube » Mon Oct 03, 2011 12:05 am

Thank you, Stefan! That fixes my problem.

User avatar
Stefan Kottwitz
Site Admin
Posts: 9436
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Mon Oct 03, 2011 3:40 pm

Hi Nathan,

it seems to be a known bug in amsmath, which is on the list for the next overhaul of the package. This can be read on TeX.SX, also another fix, I posted the problem there for hopefully finding a better fix:

Why do arguments to nested \tilde or \breve commands reappear when amsmath is used?

Stefan
Site admin


Return to “Math & Science”

Who is online

Users browsing this forum: No registered users and 3 guests