LaTeX forum ⇒ Math & Scienceproblem with closed volume integral in latex

Information and discussion about LaTeX's math and science related features (e.g. formulas, graphs).
abrarn17
Posts: 2
Joined: Tue Jun 22, 2021 10:32 am

problem with closed volume integral in latex

Postby abrarn17 » Tue Jun 22, 2021 10:49 am

Hello everyone

I am having problem with closed volume integral in latex
i used \oiint for surface integral its working perfectly but \oiiint is not working in my compilation.

my latex syntax is

\begin{equation}
\frac{\partial}{\partial t}\iiintop_{\forall} \rho d\forall 
+\oiintop_S \rho \vec{V}.\vec{dS}=0
\end{equation}


What i am getting is

z1.png
I am getting this
z1.png (25 KiB) Viewed 1510 times


what i expect

z2.png
I expect this to come
z2.png (12.63 KiB) Viewed 1510 times


Thanks
Last edited by Stefan Kottwitz on Wed Jun 23, 2021 8:51 am, edited 1 time in total.
Reason: code marked

User avatar
Ijon Tichy
Posts: 526
Joined: Mon Dec 24, 2018 10:12 am

Postby Ijon Tichy » Tue Jun 22, 2021 11:55 am

What do you mean with: “\oiiint is not working”? Have you loaded one of the packages, that provide \oiiint (→ symbols-a4)?

Can you please show a Infominimal working example to make your problem reproducible? And can you please use code tags to mark code? Otherwise the online editor/compiler provided by latex.org would not be activated.

abrarn17
Posts: 2
Joined: Tue Jun 22, 2021 10:32 am

Postby abrarn17 » Thu Jun 24, 2021 6:09 pm

Hi Ijon Tichy

here is my sample tex script

\documentclass[a4paper,12pt,twoside]{book}
%\documentclass[12pt,a4paper]{exam}
\usepackage{blindtext}
\usepackage[T1]{fontenc}
\usepackage{array}
\usepackage{booktabs}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\pagestyle{headings}
\usepackage{enumitem}
\usepackage[dvipsnames]{xcolor}
\usepackage{graphicx}
\usepackage{amsmath,amssymb}
\usepackage{wasysym}
\usepackage{amsmath,esint}
\usepackage[supplier-typeface]{mathdesign}
\makeatletter
\newcommand{\mathleft}{\@fleqntrue\@mathmargin0pt}
\newcommand{\mathcenter}{\@fleqnfalse}
\makeatother
\usepackage[makeroom]{cancel}

\usepackage{xcolor}
\colorlet{RED}{red}
\protected\def\myred{\color{red}}
\usepackage[dvipsnames]{xcolor}
\usepackage[skins,theorems]{tcolorbox}
\usepackage[export]{adjustbox}
\usepackage[margin=0.875in]{geometry}
\usepackage{amssymb,amsfonts,bm}
\usepackage{subfigure,float,multirow}

\begin{document}

\begin{equation}
 %\oiintop_S  p \vec{dS} = \iiint_V \nabla p d{\forall}
 \oiintop_S  p \vec{dS} = \oiiint_V \nabla p d{\forall}
\end{equation}

\end{document}
Last edited by Stefan Kottwitz on Thu Jun 24, 2021 7:00 pm, edited 1 time in total.

User avatar
Ijon Tichy
Posts: 526
Joined: Mon Dec 24, 2018 10:12 am

Postby Ijon Tichy » Thu Jun 24, 2021 7:55 pm

This is far from being minimal. However, it seems you are not loading one of the packages, that provide \oiiint. See the linked document in my previous posting for more information about the alternatives of those packages.

BTW: subfigure is deprecated for decades and should not be used any longer. See the link for alternatives.

And you should not load packages more than once. It is not a fault, but it often results in an fault, e.g., if options are changed at one loading but not at the other.


Return to “Math & Science”

Who is online

Users browsing this forum: No registered users and 4 guests