LaTeX forum ⇒ Graphics, Figures & Tableseps figure displayed as blank in document

Information and discussion about graphics, figures & tables in LaTeX documents.
Posts: 10
Joined: Tue May 10, 2011 5:24 pm

eps figure displayed as blank in document

Postby asims » Tue May 10, 2011 5:49 pm


I have a figure to include in my thesis (bplot.eps) which was created by printing to ps from Minitab. I then opened the image in gsview32 v4.9 successfully and converted to an EPS by defining the desired bounding box.

I then tried to include the image in my latex document using the following code:

  1. \begin{figure}%
  2. \includegraphics[width=0.9\textwidth]{04_chapter/images/bplot.eps}%
  3. \caption{caption}%
  4. \label{fig:CPAP_FEA_rgd_040}%
  5. \end{figure}

The docuement processed without any errors, but displayed blank space instead of my figure in the document. The caption was in the correct location. I tried compiling it in draft mode and the correct box outline and filename were printed.

I have included many images in this document without a problem before this.

Thank you for any comments or suggestions to resolve this issue.


Andrew Sims

User avatar
Stefan Kottwitz
Site Admin
Posts: 9403
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Tue May 10, 2011 6:56 pm

Hi Andrew,

welcome to the board!

There are tools which are able to fix eps files or to fix their bounding boxes, such as ps2eps.

Perhaps consider converting eps files to pdf (using epstopdf tool or the LaTeX package with the same name) and use pdfLaTeX. This engine has its advantages also if not using its jpg, png, pdf support.

Site admin

Posts: 10
Joined: Tue May 10, 2011 5:24 pm

Postby asims » Wed May 11, 2011 3:54 am


Thanks for the welcome and reply.

I might be a bit far down the line to simply change to using pdflatex. I am using a number of matlab plots along the way that I have used the psfrag utility to match typefaces etc where possible. I understand that the psfrag functionality is not compatible with pdflatex.

Will have to think.

As for this problem - I think that I might be getting out of the bounds of the scope of the forum here, as I have not been able to get ps2eps to work. It simply hangs as follows:

  1. C:\users\asims\PhD\tests\cpap_mri>ps2eps
  2. Input files: -
  3. Processing: -
  4. Calculating Bounding Box...Terminating on signal SIGINT(2)

This had to be terminated with CTRL-C (I am on Windows XP).

I have tried several of the debug options, but no luck. There might be something strange in the postscript files, but am not sure on that.


Andrew Sims

Posts: 8
Joined: Mon Sep 24, 2018 6:18 pm

Postby afa0011 » Mon Sep 24, 2018 7:48 pm

I have the same problem now. were you able to come up with a solution?

Return to “Graphics, Figures & Tables”

Who is online

Users browsing this forum: No registered users and 3 guests