LaTeX forum ⇒ Text FormattingFilling Text not generated with Language Specifications Topic is solved

Information and discussion about LaTeX's general text formatting features (e.g. bold, italic, enumerations, ...)
xjrecina00
Posts: 2
Joined: Wed Nov 27, 2013 1:57 pm

Filling Text not generated with Language Specifications

Postby xjrecina00 » Wed Nov 27, 2013 2:04 pm

This works (generate lorem ipsum paragraphs):
  1. \documentclass[12pt]{report}
  2. \usepackage[utf8]{inputenc}
  3.  
  4. \usepackage{lipsum} % just to generate filler text
  5.  
  6. \begin{document}
  7.  
  8. \chapter{Some Chapter}
  9. \lipsum[1-4]
  10.  
  11. \chapter{Neeext}
  12. \lipsum[1-4]
  13.  
  14. \end{document}


This does not work. Why? I only add (specify) czech for babel.
  1. \documentclass[12pt]{report}
  2. \usepackage[czech]{babel}
  3. \usepackage[utf8]{inputenc}
  4.  
  5. \usepackage{lipsum} % just to generate filler text
  6.  
  7. \begin{document}
  8.  
  9. \chapter{Some Chapter}
  10. \lipsum[1-4]
  11.  
  12. \chapter{Neeext}
  13. \lipsum[1-4]
  14.  
  15. \end{document}

Tags:

User avatar
nlct
Posts: 275
Joined: Thu Nov 06, 2008 11:15 am

Postby nlct » Wed Nov 27, 2013 2:53 pm

For some language settings, babel makes the hyphen character active. You need to switch that off via \shorthandoff{-} in this type of situation:
  1. \documentclass[12pt]{report}
  2. \usepackage[czech]{babel}
  3. \usepackage[utf8]{inputenc}
  4.  
  5. \usepackage{lipsum} % just to generate filler text
  6.  
  7. \begin{document}
  8. \shorthandoff{-}
  9.  
  10. \chapter{Some Chapter}
  11. \lipsum[1-4]
  12.  
  13. \chapter{Neeext}
  14. \lipsum[1-4]
  15.  
  16. \end{document}

Regards
Nicola Talbot

xjrecina00
Posts: 2
Joined: Wed Nov 27, 2013 1:57 pm

Postby xjrecina00 » Wed Nov 27, 2013 4:33 pm

Thanks. It helps a lot.


Return to “Text Formatting”

Who is online

Users browsing this forum: No registered users and 3 guests