LaTeX forum ⇒ Text FormattingGetting started with MusixTeX

Information and discussion about LaTeX's general text formatting features (e.g. bold, italic, enumerations, ...)
ibaldwin
Posts: 6
Joined: Wed Nov 28, 2012 3:32 pm

Getting started with MusixTeX

Postby ibaldwin » Thu Nov 29, 2012 2:28 am

Hi there,

I have a very basic MusixTeX problem. I've reduced my original score to the essential code giving me such a problem:
  1. \input musixtex
  2. \instrumentnumber{1}
  3. \setstaffs1{1}
  4. \generalsignature{2}
  5. \generalmeter{\meterfrac44}
  6. \startmuflex
  7. \nostartrule\startpiece
  8. \NOtes \qu{h} \en
  9. \endpiece
  10. \endmuflex
  11. \bye
Now, that's a fairly basic MusixTeX setting but the result is this:
example-output.png
example-output.png (1.52 KiB) Viewed 5858 times


That is, the note at pitch h shoudl be the a1, in the middle of the staff and not entirely below the staff. I've been through the MusixTeX manual several times - and it says nothing special about any additional adjustments as for the elevation of the stuff that should be typeset in the staff. I assume it should work as is.

I've got this problem on a manually installed MusixTeX with the MusixTeX fonts also installed manually straight from the Werner Icking site; then I have completelly removed my MikTeX distribution and went througha fresh installation and automatic installation of all the MusixTeX stuff and I have the same problem.

The only thing I was able to discover is that if I change the \startpiece to \startextract and \endpiece to \endextract (i.e. if I typeset an extract rather then a whole piece) that then all is typeset correctly, also in my original score. However, extract doesn't support breaking staffs : regardless of linebreak commands it sets the entire score in one single line, which is obviously not very useful as it exceeds the page. Changing it to \startpiece blows up the notes all over the page. Any ideas what's wrong?

Ian
Last edited by cgnieder on Thu Nov 29, 2012 12:19 pm, edited 1 time in total.
Reason: added inline code markup

Tags:

User avatar
Johannes_B
Site Moderator
Posts: 4140
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Thu Nov 29, 2012 11:40 am

The code works fine for me on Tex Live 2012 and MikTex 2.9. Have you tried to install Musixtex via the Package Manager? This way, all files are installed correctly and at the right place.
Attachments
musix.pdf
(17.78 KiB) Downloaded 452 times
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

ibaldwin
Posts: 6
Joined: Wed Nov 28, 2012 3:32 pm

Postby ibaldwin » Fri Nov 30, 2012 12:43 am

Hi Johannes,

Thanks for your help. Yes, I have done a very fresh installation of the whole MikTeX just yesterday with the MusixTeX installed by the package manager. Before that, I have completely removed everything that may had any connection with my old MikTeX (I even went through Windows registry and removed everything that I was able to find out was related to the old MikTeX distribution).

So, if you say that works for you, then it must be something deeper in my very installation of Windows. I'll have to dig that out.

Ian

User avatar
Johannes_B
Site Moderator
Posts: 4140
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Fri Nov 30, 2012 1:29 am

It might be a problem with your viewer. Could you please check it out with a different one?
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

ibaldwin
Posts: 6
Joined: Wed Nov 28, 2012 3:32 pm

Postby ibaldwin » Sat Dec 01, 2012 2:57 pm

Hi Johannes,

Thanks for your concerns. No, it was not viewer. It was just that I happen to eliminate the white spaces (i.e. the spaces and newlines) out of the sample code in my first mail assuming that it would better fit inside the post.

And, yes, that was the sole point: every white space messes up the MusixTeX output - i.e. there should be no whitespaces whatsoever in the code, except for the obvious cases as for example when one wants to code \wh J, then there should be a white space between the macro and the pitch designator. The safest way is to put % at the end of each line. Even the newline between the (carefully condensed) code for the score and before the \endpiece has had the effect of exploding the notes in the output all over the page.

I didn't seriously take the warning in the MusixTeX manual:

MusixTeX forgives nothing !

And according to my experience, it's true. However, as I'm starting to respect this fact, everything seems to just fall into its right place in my scores, so the problem has been solved.

Thanks Johannes again for your help

Ian

User avatar
cgnieder
Site Moderator
Posts: 1990
Joined: Sat Apr 16, 2011 7:27 pm

Postby cgnieder » Sat Dec 01, 2012 4:12 pm

ibaldwin wrote:Hi Johannes,

Thanks for your concerns. No, it was not viewer. It was just that I happen to eliminate the white spaces (i.e. the spaces and newlines) out of the sample code in my first mail assuming that it would better fit inside the post.


Another wonderful example that shows why MWEs must be the same as the error producing code... :) I naturally assumed you had troubles with the code exactly as you posted it.

Best
site moderator & package author


Return to “Text Formatting”

Who is online

Users browsing this forum: No registered users and 1 guest