LaTeX forum ⇒ Text FormattingMostly backmatter in ClasicThesis Topic is solved

Information and discussion about LaTeX's general text formatting features (e.g. bold, italic, enumerations, ...)
jan_w
Posts: 5
Joined: Tue Mar 13, 2018 1:03 pm

Mostly backmatter in ClasicThesis

Postby jan_w » Tue Mar 13, 2018 1:11 pm

I have writing a thesis some difficulties in having it my way. I hope someone can help me out with this wonderful programming.

1
In the backmatter regarding Contents I am having trouble with making:
‘Contents’ - into ‘Indhold’ (Danish)
‘List of figures’ - into ‘Liste over figurer’ as well as the underlying - into Figur 1, Figur 2 …
‘List of tables - into ‘Liste iver tabeller’ as well as the underlying - into Tabel 1, Tabel 2 …
‘Acronyms’ in the page heading - into ‘Forkortelser’
2
Is it possible to change the naming of ‘Part 1’, ‘Part 2’ etc. - into ‘Del 1’, ‘Del 2’ …
3
In the backmatter regarding Bibliography is it possible to change (cit. on p. …) - into (cit. på s. …)

Best
Jan

User avatar
Johannes_B
Site Moderator
Posts: 3905
Joined: Thu Nov 01, 2012 4:08 pm

Postby Johannes_B » Tue Mar 13, 2018 1:42 pm

You have to pass option danish to babel.
The smart way: Calm down and take a deep breath, read posts and provided links attentively, try to understand and ask if necessary.

User avatar
Stefan Kottwitz
Site Admin
Posts: 9197
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Wed Mar 14, 2018 4:11 am

Such as

\usepackage[danish]{babel}

or

\PassOptionsToPackage{danish}{babel}

Stefan
Site admin

jan_w
Posts: 5
Joined: Tue Mar 13, 2018 1:03 pm

Postby jan_w » Wed Mar 14, 2018 12:44 pm

Just tried, but nothing happened, still the same english. Do you have any idea what I might do wrong.

Jan

User avatar
Stefan Kottwitz
Site Admin
Posts: 9197
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Wed Mar 14, 2018 2:13 pm

Open ClassicThesis.tex and check the document class options:

\documentclass[twoside,openright,titlepage,...%
ngerman,american%
]{scrreprt}


Remove ngerman, american, or english, and place danish here.

Look if you find \selectlanguage{..} in the same file. Remove it, or change it to \selectlanguage{danish}.

In ClassicThesis-config.tex do the same where you find

\PassOptionsToPackage{francais,american}{babel}

Change that to

\PassOptionsToPackage{danish}{babel}

Stefan
Site admin

jan_w
Posts: 5
Joined: Tue Mar 13, 2018 1:03 pm

Postby jan_w » Wed Mar 14, 2018 3:16 pm

Thank you, thank you, thank you.
Is was what was needed, now it looks awesome in Danish.

Jan

jan_w
Posts: 5
Joined: Tue Mar 13, 2018 1:03 pm

Postby jan_w » Wed Mar 14, 2018 4:29 pm

I was a little fast on the trigger.

In the thesis I find the old namings of figure and table, how come.
Udklip.JPG
Udklip.JPG (46.94 KiB) Viewed 1339 times


Jan

jan_w
Posts: 5
Joined: Tue Mar 13, 2018 1:03 pm

Postby jan_w » Wed Mar 14, 2018 5:25 pm

Sorry

I saw the mistake.
I should add \addto\extrasdanish{% and then it works.

Jan

User avatar
Stefan Kottwitz
Site Admin
Posts: 9197
Joined: Mon Mar 10, 2008 9:44 pm

Postby Stefan Kottwitz » Wed Mar 14, 2018 5:28 pm

Good to hear that it works! Thanks for the update.

Stefan
Site admin


Return to “Text Formatting”

Who is online

Users browsing this forum: Google [Bot] and 9 guests