LaTeX forum ⇒ WinShellOne or more errors occurred! Please check the options!

Information and discussion about WinShell, a free integrated LaTeX environment for Windows
dingram2
Posts: 1
Joined: Thu Feb 04, 2010 12:26 pm

One or more errors occurred! Please check the options!

Postby dingram2 » Thu Feb 04, 2010 12:33 pm

Hi I have installed miktex, ghostcript, ghostview and winshell in that order. I don't know why I'm getting this error. I have searched the internet for a solution but I couldn't find one. Any help would be greatly appreciated.

Recommended reading 2021:

LaTeXguide.org • LaTeX-Cookbook.net
LaTeX Beginner's Guide LaTeX Cookbook
User avatar
localghost
Site Moderator
Posts: 9203
Joined: Fri Feb 02, 2007 12:06 pm

One or more errors occurred! Please check the options!

Postby localghost » Thu Feb 04, 2010 7:36 pm

dingram2 wrote:[...] I have searched the internet for a solution but I couldn't find one. [...]

FAQ - LaTeX, pdfLaTeX, DVIPS, BibTeX - "One or more errors occured! Please check the options!" : WinShell


Best regards and welcome to the board
Thorsten
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

User avatar
idb
Posts: 6
Joined: Wed Nov 03, 2021 1:04 pm

One or more errors occurred! Please check the options!

Postby idb » Wed Nov 03, 2021 1:37 pm

Hi,

as the FAQ page is not online any longer, here is the information:

This problem occurs when the Latex binary path is not in your PATH environment variable and should not happen after a correct installation of the LaTeX package. WinShell should be installed at the end of the complete installation procedure.

There are 2 possibilities to solve this problem (use one of them). For other than MikTeX distributions, it works analogue.

1. In WinShell go to Options -> Program Calls and browse for latex.exe, bibtex.exe, etc. E. g., instead of "latex.exe" in the exe-line of the LaTeX settings you will have "C:\Program Files\MiKTeX\bin\latex.exe" and so on.

2. Set the LaTeX binary path (assuming it is "C:\Program Files\MiKTeX\bin") to your PATH environment variable of your system:
Go to Start -> Control Panel -> System and Security -> System -> Advanced System Settings

Choose the 'Advanced' tab and than 'Environment Variables'. Look for 'PATH' in the list and choose 'Edit' and add ";C:\Program Files\MiKTeX\bin". Restart WinShell.

"C:\Program Files\MiKTeX\bin" is a place holder. You have to take the LaTeX binary. Maybe it's "C:\texmf\MiKTeX\bin" on your computer. It's the directory where you can find the "latex.exe" executable file.

best regards Ingo
WinShell developer, www.winshell.org


Return to “WinShell”

Who is online

Users browsing this forum: No registered users and 2 guests