LaTeX forum ⇒ LEdDvi viewer only showing blue squares Topic is solved

Information and discussion about LEd, an integrated LaTeX environment for Windows
Posts: 2
Joined: Wed Nov 04, 2009 8:41 pm

Dvi viewer only showing blue squares

Postby anderssson » Wed Nov 04, 2009 8:46 pm


As the subject says, i got a problem with the built in dvi viewer only showing the blue squares. I've tried some different versions of both miktex and the LEd but it still don't work. Also i got both ghostscript and GSview 4.9 installed on my computer.

I've done all thing in the "How To Start" guide. I would be really happy if someone could help me out with this. I need the program to work so i can finish my math project.

Posts: 126
Joined: Fri May 01, 2009 1:43 pm

Postby fatra2 » Thu Nov 05, 2009 9:52 am

Hi there,

You did not mention what you include that creates the blue square. I believe if you are using dvips in your documentclass options, then you compile and create a .dvi file. It happens often that the dvi viewer (e.g. yap) cannot display the graphic/image you included in your code. It is there, just not displayed. The best way to verify that everything works fine is to print your document (either a hardcopy, or .pdf).


Posts: 2
Joined: Wed Nov 04, 2009 8:41 pm

Postby anderssson » Thu Nov 05, 2009 8:56 pm

Well, i got it working now, used same files to install everything. the only different was that i installed it into my girlfriends laptop which is using windows vista instead of xp.

Posts: 1
Joined: Sun Jan 10, 2010 4:36 pm

Postby BlackXanthus » Sun Jan 10, 2010 4:37 pm

Interestingly, I also have this problem. I'm running on Windows 7, which I realise is a little new, and not exactly supported.

I wonder what the difference could be between windows XP and Vista that would make it work for the previous poster. Any ideas?


Posts: 6
Joined: Fri Jan 22, 2010 2:50 pm

Postby CeoN » Fri Jan 22, 2010 2:59 pm

I got the DVI-Viewer to work in Windows 7 and Windows XP by accident:

Windows 7 Professional
MiKTeX 2.8
Ghostscript 8.70 (64)
LEd Standard Edition version 0.53 beta (build 6501)

In Configuration->Options->Application->DVI Viewer select:
TeX executables: your bin directory of miktex 2.8 ... for example C:\Program Files (x86)\MiKTeX 2.8\miktex\bin
GSDLL32.DLL: C:\Program Files\gs\gs8.70\bin
Postscript fonts: C:\Program Files\gs\gs8.70\lib
TeX distribution: MikTeX2.7 and NOT MiKTeX2.8
font searching library: MiKTeX207-core.dll
font making script: makepk.exe
fallback font: cmr10
mode: ljfour
resolution: 600 dpi

The important part is the bold marked MiKTeX2.7. Before, and resulting in the blue squares mentioned in the first post of this thread i used here MiKTeX2.8 (which is installed) and trying to use MiKTeX208-core.dll in the font searching library path. However the MiKTeX208-core.dll was never saved by LEd and instead reset automatically by the program to MiKTeX207-core.dll. So in the end, a bit unusual, since MiKTeX2.7 is not installed :) but it works somehow.
I made the authors of LEd aware of this bug. Maybe we will see an update in near future. Tell me if this "workaround" works for you too.

Posts: 4
Joined: Sat Jan 30, 2010 4:05 pm

Postby emin351 » Sat Jan 30, 2010 7:51 pm

I have also same problem with Win7 64 bit. I've tried that but it didn't work for me. How can I solve this blue square problem?

Posts: 6
Joined: Fri Jan 22, 2010 2:50 pm

Postby CeoN » Sun Jan 31, 2010 2:04 pm

Hi Emin,

not that i know the solution for your workaround, but a little more information would be helpful. You did install everything similar to my configuration? And configured LEd exactly the same?

Windows7 Pro, Miktex2.8, Led (newest version), Ghostscript 8.7?
Which language did you choose for the LEd program interface? You might try here the original setup which should be english in case you switched it.

Posts: 1
Joined: Thu Feb 25, 2010 5:35 pm

Postby Ppdy » Thu Feb 25, 2010 6:17 pm

Hi Folks,

I have being trying all of the above but it never works for me (W XP home spk2, completely updated via windows automatic update; latest update installed spk3 a week ago and the notebook works fine):
I have MikTeX, latest (V. 2.8582) with Led latest (v. 0.336501) installed: the built-in dvi viewer just shows squares for several settings after compilation:
- When I apply the settings: TeX distribution: MikTeX2.7 - font searching library: MiKTeX207-core.dll as suggested LED just crashed after compilation. I have tried all other combination settings from the 2 drop menu boxes: An the outcome is either LED compiled succesfully but with the DVI viewer only showing blue/or gray squarres, either it compiled successfully but crashed immediately. As suggested elsewhere I tried one more thing: copy the dvi_miktex28.dll from the LED installation folder to the Miktex bin, using the setting (TeX distribution: MikTeX2.8 - font searching library: dvi_miktex28.dll {I had to type it in}], but LED will only crash after compilation. I have tried this new setting font searching library: dvi_miktex28.dll) with the Tex distribution setting from the drop menu, but as already mention; either a crash a dvi viewer showing only squares. However in all cases LED compilation generated all associated files; eg even the .dvi file which I can open with the external Yap in the MikteX distribution!!

Well folks, does anyone still some ideas how to solve this issue with the LED built-in DVI viewer?
NB: I have check in my MikTeK 2.8 bin (updated right after install) and only found one dvi viewer (YAP); I know of another dvi viewer called windvi (not there in the distribution): Might this have anything to do with the way LED built-in viewer communicate with MikTex? I know this question is a bit stupid since the viewer in MikTeX bin, whatsoever, is external to LED anyway.... but who knows?.....

Posts: 6
Joined: Thu Mar 11, 2010 3:19 pm

Postby AP » Thu Mar 11, 2010 3:24 pm

I have/had the same problem. Interestingly sometimes my previewer works, sometimes LEd crashes. However, what I have found out might work for you as well:

1. Follow the instructions by CeoN
2. Try compiling to DVI.
3. If LEd crashes, open the resulting DVI file with Yap. It will create the needed fonts.
4. Close Yap, delete the DVI file, start LEd.
5. Make sure the settings are still set to MikTeX 2.7 and MiKTeX207-core.dll. Compile again to DVI.

Hope it works for you too!

Posts: 1
Joined: Mon Jan 25, 2010 1:55 am

Postby kaneinf » Sun Jun 27, 2010 3:46 am

I was having this problem, but only with my figures. I use all .eps for my graphics, and, while the text was showing up in the viewer fine, the .eps would only show up in Yap, or after being output to a pdf.

I finally got fed up, and started messing around - what fixed it for me was changing to an earlier version of Ghostscript (8.54 in my case). This is an easy fix, since you can have any number of Ghostscript versions installed simultaneously. Hope it works for someone else who has this problem.

I'm using MiKTeX 2.8 (but telling LEd I have 2.7, as discussed in this thread), LEd 0.536501, and I'm on Windows XP.

Return to “LEd”

Who is online

Users browsing this forum: No registered users and 1 guest