LaTeX forum ⇒ Feature SuggestionsUnicode support

Suggestions and discussions for new TeXnicCenter features
wuntzt
Posts: 3
Joined: Fri Mar 28, 2008 12:51 pm

Re: Unicode support

Postby wuntzt » Fri Mar 28, 2008 1:17 pm

Hi there,
I've come across the same problem mentioned here - wanting to write a document using Russian and German.
Before that project I only used TexNicCenter, it supporting German when the system's non-Unicode support (via the control panel) is switched to German.

Now - the TexMaker doesn't really do it for me, as it neither gives me a mixed output.

I do want to use zerspinsboson's advise, as I'm really in need for some results here.
zerospinboson wrote:well, an interim solution that might work well for you might be to use an unicode-enabled 'feature-rich' text editor (personally, i use notepad++), set the encoding type to utf8 without BOM, and do the actual typing inthere.


I downloaded notepad++, am not quite sure on how to work it now. Do I type the text in it and then copy/paste it into TexNicCenter just for the compiling process to pdf?
What is the advantage of notepad++? Is it "only" the fact that is takes Russian as well as German letters in "utf8 without BOM"-mode?

Thanks for your advises.
wuntzt

labicia
Posts: 1
Joined: Wed May 05, 2010 2:39 pm

Postby labicia » Wed May 05, 2010 2:51 pm

Thanks to notepad++ I was able to write an abstract in Greek under windows xp.

Ιn the preamble of the latex document I put:
\usepackage[greek]{babel}
\usepackage[iso-8859-7]{inputenc}

Then in notepad++ I click on
Encoding > Character sets > Greek > ISO 8859-7

I press Alt+Shift and start typing directly in Greek.

(The Alt+Shift comes from a previous setting that I have made in windows to fix the Regional and Language option, to be able to switch between Greek and English)

Have a nice day!!
Marco

benibela
Posts: 97
Joined: Thu Aug 09, 2007 8:13 pm

Postby benibela » Thu May 06, 2010 4:30 pm

In Texmaker/TexMakerX it should be possible to write in Greek in exactly the same way like labicia described it in notepad++.
But before you can type/create a document you should probably also change the encoding of new documents to either ISO 8859-7 or UTF-8/16. (in options/configure/editor)

BeniBela


Return to “Feature Suggestions”

Who is online

Users browsing this forum: No registered users and 2 guests